brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Graham Ashby" <Graham.As...@ca.ibm.com>
Subject Re: Brooklyn Tosca
Date Tue, 08 Nov 2016 15:03:09 GMT
I followed the doc you gave, and I'm working with AMP 
When I get to the using a4c to create an application, I drag 2 compute 
nodes, then drag a tomcat server onto one of the compute nodes,  When I do 
this, I get a 404 error popup, and the diagram doesn't change:



However, the Tomcat server is in the yaml.

topology_template:
  node_templates:
    Compute-2:
      type: brooklyn.nodes.Compute
    Compute:
      type: brooklyn.nodes.Compute
    TomcatServer:
      type: org.apache.brooklyn.entity.webapp.tomcat.TomcatServer
      properties:
        download.url: "
http://download.nextag.com/apache/tomcat/tomcat-7/v$
{version}/bin/apache-tomcat-${version}.tar.gz"
        softwareProcess.serviceProcessIsRunningPollPeriod: 5 s
        dontRequireTtyForSudo: false
[etc]

Any idea what's going on?

Thanks
Graham




From:   Valentin Aitken <valentin.aitken@cloudsoftcorp.com>
To:     dev@brooklyn.apache.org
Date:   11/01/2016 07:00 PM
Subject:        Re: Brooklyn Tosca



Hi Graham,

The A4C version which we tested is 1.1.0-SM8
Can you share what is the topology diagram which you are looking at?

Here is an updated version of the post [1] which is tested with the latest 
Cloudsoft AMP 4.1.0 (the enterprise version of Apache Brooklyn)
This document should be applicable if compiling brooklyn-tosca against 
current snapshot of Apache Brooklyn.

Valentin.

[1] http://docs.cloudsoft.io/operations/tosca/

<div>-------- Original message --------</div><div>From: Graham Ashby 
<Graham.Ashby@ca.ibm.com> </div><div>Date:01/11/2016  21:20  (GMT+02:00)

</div><div>To: Brooklyn dev <dev@brooklyn.apache.org> </div><div>Subject:

Brooklyn Tosca </div><div>
</div>I'm trying to get the Tosca bridge working with alien4cloud

I'm using this as a guide: http://www.cloudsoft.io/drag-and-drop-tosca/

However, the bits don't seem to work together.  If I do this from 
brooklyn-tosca HEAD,  compiling it, The version of A4C doesn't seem to 
function properly (the topology diagrams aren't right and I get 404 
errors)

I tried various combinations of versions, but nothing has worked yet.

Does anyone know which versions I should use so that it all Just Works?

Thanks
Graham Ashby





Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message