brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Svetoslav Neykov (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (BROOKLYN-3) Build fails with Java 8
Date Mon, 21 Nov 2016 11:03:58 GMT

     [ https://issues.apache.org/jira/browse/BROOKLYN-3?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Svetoslav Neykov resolved BROOKLYN-3.
-------------------------------------
    Resolution: Fixed

Builds fine with Java 8 now. Currently used version of Groovy compiler works with Java 8.

> Build fails with Java 8
> -----------------------
>
>                 Key: BROOKLYN-3
>                 URL: https://issues.apache.org/jira/browse/BROOKLYN-3
>             Project: Brooklyn
>          Issue Type: Bug
>         Environment: Java 8
>            Reporter: Svetoslav Neykov
>
> The build fails when Java 8 is used. The groovy compiler doesn't support Java 8.
> Groovy 2.3 is the first version to officially supports Java 8, while the project uses
1.8. The groovy-eclipse-compiler used in the maven build is in the process of releasing a
version supporting Java 8 (with Groovy 2.3) - see https://jira.codehaus.org/browse/GRECLIPSE-1733



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message