brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From googlielmo <...@git.apache.org>
Subject [GitHub] brooklyn-server issue #427: Use servicemix bundle for okio
Date Fri, 11 Nov 2016 09:48:18 GMT
Github user googlielmo commented on the issue:

    https://github.com/apache/brooklyn-server/pull/427
  
    @aledsage cc: @neykov @andreaturli 
    I played a little with this and my conclusion is that since `jclouds-http` imports both
`okhttp` and `okio`, having restricted the dependency `okhttp` -> `okio` will force the
more specific version of `okio` to be wired to it.
    That said, I'm worried that `jclouds-http` doesn't seem to specify a version for `okhttp`,
which might cause it to wire to `okhttp` 3 (maybe?). Better report that to the jclouds team.


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message