brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From aledsage <...@git.apache.org>
Subject [GitHub] brooklyn-server issue #362: bump httpcomponents versions
Date Sat, 08 Oct 2016 12:22:42 GMT
Github user aledsage commented on the issue:

    https://github.com/apache/brooklyn-server/pull/362
  
    This is probably ok, but we should double-check the conflicting dependencies (e.g. will
it cause runtime errors in `httpasyncclient:jar:4.1` (a dependency of `cxf-rt-transports-http-hc`,
which is needed by winrm4j)). There may well be other conflicts as well:
    ```
    [INFO] |  |  +- org.apache.brooklyn:brooklyn-software-winrm:jar:0.10.0-SNAPSHOT:compile
    [INFO] |  |  |  +- (org.apache.brooklyn:brooklyn-core:jar:0.10.0-SNAPSHOT:compile - omitted
for duplicate)
    [INFO] |  |  |  +- io.cloudsoft.windows:winrm4j:jar:0.4.0:compile
    [INFO] |  |  |  |  \- io.cloudsoft.windows:winrm4j-client:jar:0.4.0:compile
    [INFO] |  |  |  |     +- org.apache.cxf:cxf-rt-transports-http:jar:3.1.4:compile
    [INFO] |  |  |  |     |  \- org.apache.cxf:cxf-core:jar:3.1.4:compile
    [INFO] |  |  |  |     |     +- org.codehaus.woodstox:woodstox-core-asl:jar:4.4.1:compile
    [INFO] |  |  |  |     |     |  \- org.codehaus.woodstox:stax2-api:jar:3.1.4:compile
    [INFO] |  |  |  |     |     \- org.apache.ws.xmlschema:xmlschema-core:jar:2.2.1:compile
    [INFO] |  |  |  |     +- org.apache.cxf:cxf-rt-transports-http-hc:jar:3.1.4:compile
    [INFO] |  |  |  |     |  +- (org.apache.cxf:cxf-core:jar:3.1.4:compile - omitted for duplicate)
    [INFO] |  |  |  |     |  +- (org.apache.cxf:cxf-rt-transports-http:jar:3.1.4:compile -
omitted for duplicate)
    [INFO] |  |  |  |     |  +- org.apache.httpcomponents:httpcore-nio:jar:4.4.1:compile
    [INFO] |  |  |  |     |  |  \- (org.apache.httpcomponents:httpcore:jar:4.4.1:compile -
omitted for conflict with 4.4.5)
    [INFO] |  |  |  |     |  \- org.apache.httpcomponents:httpasyncclient:jar:4.1:compile
    [INFO] |  |  |  |     |     +- (org.apache.httpcomponents:httpcore:jar:4.4.1:compile -
omitted for conflict with 4.4.5)
    [INFO] |  |  |  |     |     +- (org.apache.httpcomponents:httpcore-nio:jar:4.4.1:compile
- omitted for duplicate)
    [INFO] |  |  |  |     |     \- (org.apache.httpcomponents:httpclient:jar:4.4.1:compile
- omitted for conflict with 4.5.2)
    ```
    
    Also, does this work in karaf? Or might some dependent bundles have been built to depend
on httpclient `[4.4,4.5)` (so fail to install, unless we include both versioned bundles in
the karaf install)?


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message