brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BROOKLYN-300) MySQL provisioning fails on centos when perl not on base OS
Date Mon, 08 Aug 2016 14:57:20 GMT

    [ https://issues.apache.org/jira/browse/BROOKLYN-300?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15411912#comment-15411912
] 

ASF GitHub Bot commented on BROOKLYN-300:
-----------------------------------------

GitHub user drigodwin opened a pull request:

    https://github.com/apache/brooklyn-library/pull/58

    Added perl install to MySQL node

    Addresses [BROOKLYN-300](https://issues.apache.org/jira/browse/BROOKLYN-300).
    
    Tested with Centos 6 and Centos 7 on BlueBox

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/drigodwin/brooklyn-library mysql-perl

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/brooklyn-library/pull/58.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #58
    
----
commit 9f1c533fd7c79afd9aa535de7168bd64e8f0f90a
Author: Duncan Godwin <duncan.godwin@cloudsoftcorp.com>
Date:   2016-08-08T14:53:08Z

    Added perl install to MySQL node

----


> MySQL provisioning fails on centos when perl not on base OS
> -----------------------------------------------------------
>
>                 Key: BROOKLYN-300
>                 URL: https://issues.apache.org/jira/browse/BROOKLYN-300
>             Project: Brooklyn
>          Issue Type: Bug
>    Affects Versions: 0.9.0
>            Reporter: Aled Sage
>
> When deploying to a (very) stripped down CentOS 7 image, MySQL failed because perl was
not pre-installed.
> To work It needs {{yum install -y perl perl-Data-Dumper}} (without the latter, we get
the error {{FATAL ERROR: please install the following Perl modules before executing /tmp/installs/MySqlNode_5.6.26/mysql-5.6.26-linux-glibc2.5-x86_64/scripts/mysql_install_db:
Data::Dumper}}).



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message