brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Duncan Grant (JIRA)" <j...@apache.org>
Subject [jira] [Created] (BROOKLYN-318) MariaDbNode fails to start on centos7 on aws
Date Thu, 28 Jul 2016 12:46:20 GMT
Duncan Grant created BROOKLYN-318:
-------------------------------------

             Summary: MariaDbNode fails to start on centos7 on aws
                 Key: BROOKLYN-318
                 URL: https://issues.apache.org/jira/browse/BROOKLYN-318
             Project: Brooklyn
          Issue Type: Bug
            Reporter: Duncan Grant
            Priority: Minor


When deploying MariaDbNode on aws on centos 7 with default config it fails to start.  Error
shows in post-launch when it fails to pass isRunning check after 2 minutes.  I have tried
the same entity on centos 7 on Softlayer and it ran OK.

Using eu-central-1/ami-9bf712f4

>From console.log:
160728 11:14:23 [ERROR] mysqld: Can't lock aria control file '/home/users/amp/brooklyn-managed-processes/apps/dx8im7ym7x/entities/MariaDbNode_g4hh2cwvws/aria_log_control'
for exclusive use, error: 11. Will retry for 30 seconds
160728 11:14:29 InnoDB: The InnoDB memory heap is disabled
160728 11:14:29 InnoDB: Mutexes and rw_locks use GCC atomic builtins
160728 11:14:29 InnoDB: Compressed tables use zlib 1.2.3
160728 11:14:29 InnoDB: Using Linux native AIO
160728 11:14:29 InnoDB: Initializing buffer pool, size = 128.0M
160728 11:14:29 InnoDB: Completed initialization of buffer pool
InnoDB: Error: space header page consists of zero bytes in data file ./ibdata1
160728 11:14:29 InnoDB: Could not open or create data files.
160728 11:14:29 InnoDB: If you tried to add new data files, and it failed here,
160728 11:14:29 InnoDB: you should now edit innodb_data_file_path in my.cnf back
160728 11:14:29 InnoDB: to what it was, and remove the new ibdata files InnoDB created
160728 11:14:29 InnoDB: in this failed attempt. InnoDB only wrote those files full of
160728 11:14:29 InnoDB: zeros, but did not yet use them in any way. But be careful: do not
160728 11:14:29 InnoDB: remove old data files which contain your precious data!
160728 11:14:29 [ERROR] Plugin 'InnoDB' init function returned error.
160728 11:14:29 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
160728 11:14:29 [Note] Plugin 'FEEDBACK' is disabled.
160728 11:14:29 [ERROR] Unknown/unsupported storage engine: InnoDB
160728 11:14:29 [ERROR] Aborting



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message