brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Geoff Macartney (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BROOKLYN-302) SSLException: close_notify in ResourceUtils getResourceAsString against https url
Date Tue, 26 Jul 2016 10:45:20 GMT

    [ https://issues.apache.org/jira/browse/BROOKLYN-302?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15393614#comment-15393614
] 

Geoff Macartney commented on BROOKLYN-302:
------------------------------------------

I had a very similar problem when running container service from home. When it tried to load
the include `https://raw.githubusercontent.com/brooklyncentral/brooklyn-etcd/release/2.1.0/catalog.bom`,
I got 

`javax.net.ssl.SSLException: Received fatal alert: close_notify` 

For me it turned out to be because I have Virgin Media as ISP and had Virgin’s “Web Safe”
parental protection mode on. Turning this off fixed the problem. What highlighted the problem
for me was doing an nslookup on raw.githubusercontent.com- the address it gave me was a Virgin
Media address rather than the github one.

YMMV

> SSLException: close_notify in ResourceUtils getResourceAsString against https url
> ---------------------------------------------------------------------------------
>
>                 Key: BROOKLYN-302
>                 URL: https://issues.apache.org/jira/browse/BROOKLYN-302
>             Project: Brooklyn
>          Issue Type: Bug
>    Affects Versions: 0.10.0
>            Reporter: Duncan Grant
>            Priority: Minor
>
> This can be reproduced by running the following in the groovy console of brooklyn but
I'm not sure when it will fail.
> {code}
> org.apache.brooklyn.util.core.ResourceUtils utils = org.apache.brooklyn.util.core.ResourceUtils.create();
>         String result = utils.getResourceAsString("https://github.com/apache/brooklyn-library/raw/master/examples/simple-web-cluster/src/main/resources/visitors-creation-script.sql");
>         System.out.println(result);
> {code}
> I have seen this consistently fail for the last few days and have tried with java versions
1.7.0_71, 1.8.0_45, and 1.8.0_92.
> Error on failure is:
> {noformat}
> 2016-06-14 16:43:13,301 WARN  Problem in user-supplied script: org.apache.brooklyn.util.exceptions.PropagatedRuntimeException:
SSLException: Received fatal alert: close_notify
> org.apache.brooklyn.util.exceptions.PropagatedRuntimeException: 
> 	at org.apache.brooklyn.util.exceptions.Exceptions.propagate(Exceptions.java:128) ~[brooklyn-utils-common-0.10.0-20160613.090333-51.jar:0.10.0-SNAPSHOT]
> Caused by: javax.net.ssl.SSLException: Received fatal alert: close_notify
> 	at sun.security.ssl.Alerts.getSSLException(Alerts.java:208) ~[na:1.8.0_92]
> {noformat}
> However this is working for me today.  This may be because I am running this from the
office rather than from home so I will try again at home this evening.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message