brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrea Turli <andrea.tu...@cloudsoftcorp.com>
Subject Re: Need help in deploying Brooklyn on OpenStack liberty
Date Wed, 22 Jun 2016 09:41:08 GMT
Interesting,

I think you can try with

location:
  jclouds:openstack-devtest-compute:
    endpoint: https://x.x.x.x:5000/v2.0/
    identity: "my-tenant:my-username"
    credential: password
    # optional
    imageId: RegionOne/image-id
    hardwareId: RegionOne/2
    templateOptions:
      networks: [ "network-id" ]
      floatingIpPoolNames: [ "name-of-my-floatingIp-pool" ]
      # optional as it should try `ubuntu` anyway - loginUser: ubuntu
      loginUser.privateKeyData: /path/to/private/key/for/loginUser
      securityGroups: security-group-name

services:
- type: brooklyn.entity.basic.EmptySoftwareProcess

Be sure that `security-group-name` opens port 22

Let us know,
Andrea



On 22 June 2016 at 11:27, Gowri LN <gowri.ln123@gmail.com> wrote:

> Hi ,
>
> Thanks a lot for the help.
>
> Unfortunately , the  images I am using does not have password configured. I
> tried the following blueprint instead
>
> location:
>   jclouds:openstack-devtest-compute:
>     endpoint: https://x.x.x.x:5000/v2.0/
>     identity: "my-tenant:my-username"
>     credential: password
>     # optional
>     imageId: RegionOne/image-id
>     hardwareId: RegionOne/2
>     templateOptions:
>       networks: [ "network-id" ]
>       floatingIpPoolNames: [ "name-of-my-floatingIp-pool" ]
>       loginUser: ubuntu
>       securityGroups: security-group-name
>       extraSshPublicKeyData: ---- BEGIN SSH2 PUBLIC KEY
> ----....my..public--key--data---- END SSH2 PUBLIC KEY ----
> name: VM-new6
> services:
> - type: brooklyn.entity.basic.EmptySoftwareProcess
>   name: Empty software process
>
>
> But Still same issue. It doesnot seem to add my key to the VM. Any
> suggestions ?
>
> On Wed, Jun 22, 2016 at 1:22 PM, Andrea Turli <
> andrea.turli@cloudsoftcorp.com> wrote:
>
> > Hi,
> >
> > good progress!
> >
> > Can you manually ssh into the VM? What's the username and password
> > configured in that imageId?
> > I suspect brooklyn can't ssh into the VM that's why the deployment may be
> > pending.
> >
> > I think you want to play with `loginUser` and `loginUser.password` to
> allow
> > the first SSH login. Find more details at [1]
> >
> > Best,
> > Andrea
> >
> > [1]: https://brooklyn.apache.org/v/latest/ops/locations/#os-setup
> >
> > On 22 June 2016 at 08:22, Gowri LN <gowri.ln123@gmail.com> wrote:
> >
> > > Hi ,
> > >
> > > I tried the following yaml:
> > >
> > > location:
> > >   jclouds:openstack-devtest-compute:
> > >     endpoint: https://x.x.x.x:5000/v2.0/
> > >     identity: "my-tenant:my-username"
> > >     credential: password
> > >     # optional
> > >     imageId: RegionOne/image-id
> > >     hardwareId: RegionOne/2
> > >     templateOptions:
> > >       networks: [ "network-id" ]
> > >       floatingIpPoolNames: [ "name-of-my-floatingIp-pool" ]
> > >       loginUser: ubuntu
> > >       # optional - user to ssh into the VM the first time (usually
> > > `ubuntu`or `root` is expected)
> > >        # overrideLoginUser: ubuntu
> > >       # overrideLoginPassword: <login password>
> > > name: VM-new
> > > services:
> > > - type: brooklyn.entity.basic.EmptySoftwareProcess
> > >   name: Empty software process
> > >
> > >
> > >  A VM gets created in openstack  with a floating IP assigned. But the
> > > application is stuck in starting state ( Provisioning> DST Manager)
> for a
> > > long time .But application is still in starting state .
> > >
> > > Any suggestions?
> > >
> > > On Tue, Jun 21, 2016 at 2:30 PM, Andrea Turli <
> > > andrea.turli@cloudsoftcorp.com> wrote:
> > >
> > > > Hi,
> > > >
> > > > Can you please try with the following YAML
> > > >
> > > > name: VM4
> > > >
> > > > services:
> > > > - type: brooklyn.entity.basic.EmptySoftwareProcess
> > > >
> > > > location:
> > > >   jclouds:openstack-devtest-compute:
> > > >     endpoint: http://x.x.x.x:5000/v2.0/
> > > >     identity: "my-tenant:my-username"
> > > >     credential: my-password
> > > >     # optional
> > > >     #imageId: RegionOne/adec65c4-de61-41ff-a4c7-f1f3163e750c
> > > >     #hardwareId: RegionOne/1
> > > >
> > > >     # templateOptions:
> > > >       # networks: [ "18073710-7e5e-4023-a117-44f963443c4c" ]
> > > >       # floatingIpPoolNames: [ "public" ]
> > > >       # optional - user to ssh into the VM the first time (usually
> > > `ubuntu`
> > > > or `root` is expected)
> > > >       # overrideLoginUser: <login username>
> > > >       # overrideLoginPassword: <login password>
> > > >
> > > > I think your yaml is quite right, but this version should simplify
> the
> > > > debugging,
> > > >
> > > > Notice, I've added some optional properties just to help you in
> > targeting
> > > > your env correctly, like imageId or hardwareId.
> > > >
> > > > In particular, the devtest-compute assumes you want to use a floating
> > IP
> > > so
> > > > you need to discover your `networkId` and the `floating ip pool name`
> > > > unless you want to run the test without the floating-ip by overriding
> > the
> > > > default with
> > > >
> > > > name: VM4
> > > >
> > > > services:
> > > > - type: brooklyn.entity.basic.EmptySoftwareProcess
> > > >
> > > > location:
> > > >   jclouds:openstack-devtest-compute:
> > > >     endpoint: http://x.x.x.x:5000/v2.0/
> > > >     identity: "my-tenant:my-username"
> > > >     credential: my-password
> > > >     jclouds.openstack-nova.auto-create-floating-ips: false
> > > >
> > > > Best,
> > > > Andrea
> > > >
> > > >
> > > > On 21 June 2016 at 09:16, Gowri LN <gowri.ln123@gmail.com> wrote:
> > > >
> > > > > Hi All,
> > > > >
> > > > > I am trying to launch a very basic VM using Apache Brooklyn 0.9 on
> > > > > OpenStack ( Liberty) setup.   I tried the jclouds-openstack-devtest
> > jar
> > > > and
> > > > > changed the location definition to openstack-devtest-compute  ( as
> > > > > suggested in - Stackoverflow-link
> > > > > <
> > > > >
> > > >
> > >
> >
> http://stackoverflow.com/questions/37652364/how-to-set-floating-ip-for-vm-using-apache-brooklyn-floating-ips-are-required/37655309?noredirect=1#comment62981578_37655309
> > > > > >
> > > > >  ) but I get an error.
> > > > >
> > > > > Yaml -
> > > > >
> > > > > location:
> > > > >   jclouds:openstack-devtest-compute:http://x.x.x.x:5000/v2.0/:
> > > > >     identity: my-tenant:my-username
> > > > >     credential: my-password
> > > > > name: VM4
> > > > > services:
> > > > > - type: brooklyn.entity.basic.EmptySoftwareProcess
> > > > >   name: Empty software process
> > > > >
> > > > > Error -
> > > > >
> > > > > > `Required entity not healthy:
> EmptySoftwareProcessImpl{id=lgMeL1qc}
> > > > > >
> > > > > > Failure running task invoking start[locations] on 1 node
> > (HxHrFqvS):
> > > > > Error
> > > > > >> invoking start at EmptySoftwareProcessImpl{id=lgMeL1qc}:
Unable
> to
> > > > > access
> > > > > >> cloud JcloudsLocation[openstack-devtest-compute:
> > > > > >>
> > > > >
> > > >
> > >
> >
> https://x.x.x.x:5000/v2.0/:my-tenant:my-password/openstack-devtest-compute:https://x.x.x.x:5000/v2.0/@cngl0O8K
> > > > > ]
> > > > > >> to resolve PortableTemplateBuilder[ports=[22], locationId=
> > > > > >> https://x.x.x.x:5000/v2.0/,
> > > > > >>
> > > > >
> > > >
> > >
> >
> imageChooserFunction=org.apache.brooklyn.location.jclouds.BrooklynImageChooser$ImageChooserFromOrdering@4d3edd1d
> > > > > ,
> > > > > >> minRam=2048]:
> > > > > >> com.google.common.util.concurrent.UncheckedExecutionException:
> > > > > >> org.jclouds.http.HttpResponseException: Connection refused
> > > connecting
> > > > to
> > > > > >> POST https://127.0.0.1/identity/v2.0/tokens HTTP/1.1`
> > > > > >
> > > > > >
> > > > > Any suggestions ?
> > > > >
> > > > > Thanks in advance!
> > > > >
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message