brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gowri LN <gowri.ln...@gmail.com>
Subject Re: Need help in deploying Brooklyn on OpenStack liberty
Date Thu, 30 Jun 2016 05:51:19 GMT
Hi Andrea,

Thanks a lot for the constant support .

I want to use my own keypair already available in OpenStack so that I can
connect to the  VM later using my keypair.

I did try as specified in yaml [1].
Now it looks like it is picking up the keypair (- may be it was my error in
the yaml before).

Though I am getting a new error :


> Error invoking start at EmptySoftwareProcessImpl{id=TrmhitVc}: chars
> PuTTY-User-Key-File-2: ssh-rsa
> Encryption: none
> Comment: imported-openssh-key
> Public-Lines: 6
> *..some lines...............*
> Private-Lines: 14 .



> .. some lines...........
> Private-MAC: 37589......................57f
> doesn't contain % line [-----BEGIN ]
>

The private key I am pointing in yaml is  generated using putty gen by
loading my key - "my-keypair"

Any suggestions ?


[1]: https://gist.github.com/andreaturli/33509ff74bb8d0cfb77d5ba36c46977e





On Mon, Jun 27, 2016 at 1:55 PM, Andrea Turli <
andrea.turli@cloudsoftcorp.com> wrote:

> Gowri,
>
> could you please share the steps you have done to provision the VM manually
> and the SSH command to access it?
>
> ---
>
> Yes, I can manually provision VM with the image ( my-image-id)  and ssh
> > into it using my-keypair .
> >
>
> when you say using `my-keypair`, do you mean, you want to use always a
> specific keypair already available on your Openstack? By default, Brooklyn
> will allocate a keypair for you, but in case this is not the behavior you
> want, you can try the following YAML at [1]
>
> Good luck,
> Andrea
>
> [1]: https://gist.github.com/andreaturli/33509ff74bb8d0cfb77d5ba36c46977e
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message