brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aled Sage <aled.s...@gmail.com>
Subject [PROPOSAL] Rename SimpleShellCommandTest to TestSshCommand
Date Tue, 07 Jun 2016 09:37:51 GMT
Hi all,

I suggest we rename the entity SimpleShellCommandTest [1] to 
TestSshCommand. This would make it more consistent with the naming of 
things like ShellFeed [2] and SshFeed [3]: "shell" means executing a 
command on the local brooklyn server, whereas "ssh" means executing a 
command on the given SshMachineLocation. Also, having the prefix "Test" 
is more consistent with TestSensor, TestEffector, TestHttpCall, etc.

I'll also add TestSshCommand.SHELL_ENVIRONMENT config key (to follow the 
naming convention of VanillaSoftwareProcess.SHELL_ENVIRONMENT).

Obviously we'd deprecate the old SimpleShellCommandTest, rather than 
deleting it.

Thoughts?

Aled

[1] http://brooklyn.apache.org/v/latest/yaml/test/index.html
[2] 
https://github.com/apache/brooklyn-server/blob/master/core/src/main/java/org/apache/brooklyn/feed/shell/ShellFeed.java
[3] http://brooklyn.apache.org/v/latest/java/feeds.html



Mime
View raw message