brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BROOKLYN-263) Explicit ports are not open for BrooklynNode in cloud
Date Wed, 11 May 2016 16:42:13 GMT

    [ https://issues.apache.org/jira/browse/BROOKLYN-263?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15280398#comment-15280398
] 

ASF GitHub Bot commented on BROOKLYN-263:
-----------------------------------------

GitHub user kiuby88 opened a pull request:

    https://github.com/apache/brooklyn-server/pull/136

    Fix/required open ports

    This PR tries to fix the issue described by issue [BROOKLYN-263](  https://issues.apache.org/jira/browse/BROOKLYN-263).
    
    `BrooklynNode` requires `brooklynnode.webconsole.httpPort` config key as a open port.
However, the config was not being considered as a open port, because `InboundPortsUtils#getRequiredOpenPorts`
just consideres either config keys whose name matches with `*.port` or config keys that are
based on `PortRanges` and that are not configured (using default values).
    
    This PR adds to `InboundPortsUtils#getRequiredOpenPorts` the capability to take in account
explicit configured config keys that are based on `PortRanges`.

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/kiuby88/brooklyn-server fix/required-open-ports

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/brooklyn-server/pull/136.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #136
    
----
commit b2ffcf242f670ef61b5b2b1d1f7e44b753f20c5e
Author: Kiuby88 <kiuby88.programming@gmail.com>
Date:   2016-05-11T16:19:19Z

    Check the required open port for BrooklynNode

commit 61d138e1a320ecf692686c8fae4b1585206217d3
Author: Kiuby88 <kiuby88.programming@gmail.com>
Date:   2016-05-11T16:21:49Z

    Inferring required open ports depending on config key value type

----


> Explicit ports are not open for BrooklynNode in cloud
> -----------------------------------------------------
>
>                 Key: BROOKLYN-263
>                 URL: https://issues.apache.org/jira/browse/BROOKLYN-263
>             Project: Brooklyn
>          Issue Type: Bug
>    Affects Versions: 0.9.0, 0.10.0
>            Reporter: Jose Carrasco
>            Priority: Minor
>              Labels: easyfix
>
> I tried to deploy a BrooklynNode entity with an explicit web console port (8082) over
a AWS VM machine. Using the following plan:
> {code:title=BluePrint|borderStyle=solid}
> name: BrooklynNode
> location: aws-ec2:us-west-2
> services:
> - type: org.apache.brooklyn.entity.brooklynnode.BrooklynNode
>   id: brooklynNode
>   brooklyn.config:
>     onExistingProperties: do_not_use
>     brooklynnode.webconsole.nosecurity: true
>     brooklynnode.webconsole.httpPort: 8082 
> {code}
> However I found an error because the entity did not look to be up (SERVICE_UP retrieved
false). Then, I tried to figure out a bit. The BrooklynNode instance was installed and executed
correctly but the VM’s security group did not have any rule to enable the 8082 port.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message