brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BROOKLYN-244) Blueprint Composer: text disappears after few seconds
Date Wed, 06 Apr 2016 11:07:25 GMT

    [ https://issues.apache.org/jira/browse/BROOKLYN-244?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15228105#comment-15228105
] 

ASF GitHub Bot commented on BROOKLYN-244:
-----------------------------------------

GitHub user tbouron opened a pull request:

    https://github.com/apache/brooklyn-ui/pull/23

    BROOKLYN-244: Fix blueprint composer loading issue

    This load straight away CodeMirror when launching the composer for the composer tab, removing
the requirement on loading the full list of applications contained within the catalog.
    
    When coming from the catalog (editing a catalog item YAML), it will temporarily disable
the editor, add an overlay displaying `Loading item...` until the item is full loaded from
the REST server and added to the editor. At that point, the overlay will fade out and the
editor enable again.

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/tbouron/brooklyn-ui fix/brooklyn-244

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/brooklyn-ui/pull/23.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #23
    
----
commit 38e89a53f9335994cff9293b57d5164c380f1d6e
Author: Thomas Bouron <thomas.bouron@cloudsoftcorp.com>
Date:   2016-04-06T11:01:32Z

    BROOKLYN-244: Fix blueprint composer loading issue

----


> Blueprint Composer: text disappears after few seconds
> -----------------------------------------------------
>
>                 Key: BROOKLYN-244
>                 URL: https://issues.apache.org/jira/browse/BROOKLYN-244
>             Project: Brooklyn
>          Issue Type: Bug
>            Reporter: Aled Sage
>
> On Brooklyn 0.9.0-SNAPSHOT...
> When I open the Blueprint Composer and start typing (particularly if I've pasted a blueprint),
then sometimes a few seconds later the text all disappears leaving me with a blank text area.
> I suspect (talking briefly to Thomas) that it could be refreshing after the catalog has
finished loading - the longer the catalog takes to be retrieved, then the longer the delay
before any text is lost.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message