brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aled Sage <aled.s...@gmail.com>
Subject Re: [CANCEL][VOTE] Release Apache Brooklyn 0.9.0 [rc2]
Date Tue, 05 Apr 2016 17:10:04 GMT
Thanks all.

John has fixed this [1]. I'll review, merge, and cherry-pick to the 
0.9.0 branch.

Given we are producing another release candidate anyway, can we include 
the fix for BROOKLYN-249 (see [2,3]). Can someone please review that and 
give their opinion for whether it should be included in the 0.9.0 release?

Aled

[1] https://github.com/apache/brooklyn-server/pull/102
[2] https://issues.apache.org/jira/browse/BROOKLYN-249
[3] https://github.com/apache/brooklyn-server/pull/103


On 05/04/2016 10:30, John McCabe wrote:
> Note that it also breaks the add location wizard in jsgui.
>
> On Tue, 5 Apr 2016 at 10:26 Richard Downer <richard@apache.org> wrote:
>
>> After discussing with John, I agree that BROOKLYN-246 is a blocker.
>> The catalog file that the Brooklyn Vagrant distributable uses is using
>> the broken format, so it won't work - and we really don't want our
>> simplest-possible-get-started to require manual modifications before
>> it'll work. It also breaks the documented way of using BYON[1] so we
>> are at high risk of breaking user's working configurations.
>>
>> Therefore due to this critical bug, I am cancelling the vote.
>>
>> Richard.
>>
>> [1]https://brooklyn.apache.org/v/latest/ops/locations/index.html#byon
>>
>> On 4 April 2016 at 18:11, John McCabe <john@johnmccabe.net> wrote:
>>> @all, I hit an issue with location handling while following up on @svets
>>> comments - https://issues.apache.org/jira/browse/BROOKLYN-246
>>>
>>> Looks like a blocker.
>>>
>>> On Mon, 4 Apr 2016 at 14:35 John McCabe <john@johnmccabe.net> wrote:
>>>
>>>> @svet, latest isn't required, 1.8+ should suffice.
>>>>
>>>> On Mon, 4 Apr 2016 at 12:53 Svetoslav Neykov <
>>>> svetoslav.neykov@cloudsoftcorp.com> wrote:
>>>>
>>>>> +1 binding
>>>>>
>>>>> * Tested the .zip & .tar.gz dists
>>>>> * Tested CLI
>>>>> * Tried a simple blueprint
>>>>> * Tested the vagrant artifact - "vagrant up" *fails* because it's
>> looking
>>>>> at the release url
>>>>>
>> https://www.apache.org/dyn/closer.lua?action=download&filename=brooklyn/apache-brooklyn-0.9.0/apache-brooklyn-0.9.0-bin.tar.gz
>>>>> <
>>>>>
>> https://www.apache.org/dyn/closer.lua?action=download&filename=brooklyn/apache-brooklyn-0.9.0/apache-brooklyn-0.9.0-bin.tar.gz
>>> .
>>>>> Once released should work.
>>>>>     Unrelated, but do we require the absolute latest vagrant version
on
>>>>> purpose? Can we relax this version requirement?
>>>>>
>>>>> Svet.
>>>>>
>>>>>
>>>>>> On 4.04.2016 г., at 13:14, Sam Corbett <
>> sam.corbett@cloudsoftcorp.com>
>>>>> wrote:
>>>>>> +1 binding
>>>>>>
>>>>>> I have:
>>>>>> * Verified release signatures
>>>>>> * Built from the source archive
>>>>>> * Generated a project from the archetype
>>>>>> * Verified all subsequent archetype instructions were correct
>>>>>> * Verified a simple application deployed to AWS.
>>>>>> * Given the CLI a work out.
>>>>>>
>>>>>>
>>>>>> On 01/04/2016 16:58, Richard Downer wrote:
>>>>>>> This is to call for a vote for the release of Apache Brooklyn
0.9.0
>>>>> [rc2].
>>>>>>> This release comprises of a source code distribution, and a
>>>>>>> corresponding binary distribution, RPM packages, Vagrant environment
>>>>>>> package, and Maven artifacts.
>>>>>>>
>>>>>>> The source and binary distributions, including signatures, digests,
>>>>>>> etc. can be found at:
>>>>>>>
>> https://dist.apache.org/repos/dist/dev/brooklyn/apache-brooklyn-0.9.0-rc2
>>>>>>> The artifact SHA-256 checksums are as follows:
>>>>>>> 426ca93aad28ac8281b2015fc0ea419cd6db19c3ed87ffd11910a6baf2e9e3ab
>>>>>>> *apache-brooklyn-0.9.0-rc2-1.noarch.rpm
>>>>>>> b2a65642fb86198b9fd9992ef3464025d9b41c453c4dd5366699d569a65709c6
>>>>>>> *apache-brooklyn-0.9.0-rc2-bin.tar.gz
>>>>>>> 999fd6f1d21417278ffe153fc1f0346d44235dfbbd39f200815f61cea82edbe5
>>>>>>> *apache-brooklyn-0.9.0-rc2-bin.zip
>>>>>>> 00e0a76775775957e92498d0b5ea3e13f844155eda3251a8ead05cf4b4a4455b
>>>>>>> *apache-brooklyn-0.9.0-rc2-src.tar.gz
>>>>>>> c7a9a286993b1d520ae6a32e25c0dd3bef7227290d59347256bd96480b70a02b
>>>>>>> *apache-brooklyn-0.9.0-rc2-src.zip
>>>>>>> 907267c5d2e7c1622e11f2bc57b6afe12ddf2136d82bad63661e43570aaa78fa
>>>>>>> *apache-brooklyn-0.9.0-rc2-vagrant.tar.gz
>>>>>>> 0ae8384426d6b7197ca3d194c1e8032b85c5bb80671157c274487220d3ba65e9
>>>>>>> *apache-brooklyn-0.9.0-rc2-vagrant.zip
>>>>>>>
>>>>>>> The Nexus staging repositories for the Maven artifacts are located
>> at:
>> https://repository.apache.org/content/repositories/orgapachebrooklyn-1016
>> https://repository.apache.org/content/repositories/orgapachebrooklyn-1017
>>>>>>> All release artifacts are signed with the following key:
>>>>>>> https://people.apache.org/keys/committer/richard.asc
>>>>>>>
>>>>>>> KEYS file available here:
>>>>>>> https://dist.apache.org/repos/dist/release/brooklyn/KEYS
>>>>>>>
>>>>>>> The artifacts were built from these Git commit IDs:
>>>>>>> brooklyn: acc8ff1930d243d2a5fae1ad2f1a1ef17ca4a19c
>>>>>>> brooklyn-client: 64573c8e1b8630f59b23356520282c91cc46a8a1
>>>>>>> brooklyn-dist: 0b8b81df458fa4323939582d9f0dda10b2f6eaee
>>>>>>> brooklyn-docs: 12430d193e1891b87a677d6b45a3b17861c83518
>>>>>>> brooklyn-library: 2565e6eb2868468ec2528df74fe85efdb887b6d2
>>>>>>> brooklyn-server: d031cea080613645219ba982c93264943798d4fc
>>>>>>> brooklyn-ui: 307382128951bb237bc351ac22136745e5d50475
>>>>>>> All of the above have been tagged as "apache-brooklyn-0.9.0-rc2".
>>>>>>>
>>>>>>>
>>>>>>> Please download the artifacts, test, and vote on releasing this
>>>>>>> package as Apache Brooklyn 0.9.0.
>>>>>>>
>>>>>>> The vote will be open for at least 72 hours.
>>>>>>> [ ] +1 Release this package as Apache Brooklyn 0.9.0 (please
>> describe
>>>>>>> the tests you have performed)
>>>>>>> [ ] +0 no opinion
>>>>>>> [ ] -1 Do not release this package (please describe why not)
>>>>>>>
>>>>>>> Thanks
>>>>>>> Richard.
>>>>>


Mime
View raw message