brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aled Sage (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (BROOKLYN-228) Brooklyn archetype fails over eclipse
Date Thu, 25 Feb 2016 12:25:18 GMT

     [ https://issues.apache.org/jira/browse/BROOKLYN-228?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Aled Sage updated BROOKLYN-228:
-------------------------------
    Summary: Brooklyn archetype fails over eclipse  (was: apache-brooklyn)

> Brooklyn archetype fails over eclipse
> -------------------------------------
>
>                 Key: BROOKLYN-228
>                 URL: https://issues.apache.org/jira/browse/BROOKLYN-228
>             Project: Brooklyn
>          Issue Type: Bug
>    Affects Versions: 0.9.0
>            Reporter: Felix Otto
>            Priority: Minor
>              Labels: build, maven
>             Fix For: 0.9.0
>
>
> I try to create a apache brooklyn quickstarter project with the archetype (mvn:org.apache.brooklyn/brooklyn-archetype-quickstart/0.9.0-20160115.1845)
over Eclipse and get the following error message:
> {code}
> Unable to create project from archetype [org.apache.brooklyn:brooklyn-archetype-quickstart:0.9.0-20160115.1845
-> http://ccweb.cloudsoftcorp.com/maven/libs-release-local]
> The defined artifact is not an archetype
> {code}
> I think the archetype was not build correctly in the pom file the maven-archetype resource
extension for the packaging is missing:
> {code:xml}
>     <extensions>
>       <extension>
>         <groupId>org.apache.maven.archetype</groupId>
>         <artifactId>archetype-packaging</artifactId>
>       </extension>
>     </extensions>
> {code}
> For further Information http://maven.apache.org/archetype/archetype-packaging/
> Thanks and Best Regards,
> Felix



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message