brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BROOKLYN-190) Upgrade to Jetty9
Date Mon, 02 Nov 2015 16:45:28 GMT

    [ https://issues.apache.org/jira/browse/BROOKLYN-190?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14985510#comment-14985510
] 

ASF GitHub Bot commented on BROOKLYN-190:
-----------------------------------------

Github user neykov commented on a diff in the pull request:

    https://github.com/apache/incubator-brooklyn/pull/997#discussion_r43649604
  
    --- Diff: parent/pom.xml ---
    @@ -208,9 +208,9 @@
                     <version>${swagger.version}</version>
                 </dependency>
                 <dependency>
    -                <groupId>org.eclipse.jetty.orbit</groupId>
    -                <artifactId>javax.servlet</artifactId>
    -                <version>${jetty-orbit-javax-servlet.version}</version>
    +                <groupId>javax.servlet</groupId>
    +                <artifactId>javax.servlet-api</artifactId>
    +                <version>${javax-servlet.version}</version>
    --- End diff --
    
    You left the dependency only in the `dependencyManagement` section in the parent pom,
which doesn't actually pull it as a dependency, just declares which version to use in case
anyone needs it. If classes from it are still directly referenced, then put it explicitly
in the `dependencies` sections in modules that need it. It works now because it's a transitive
dependency of jetty.


> Upgrade to Jetty9
> -----------------
>
>                 Key: BROOKLYN-190
>                 URL: https://issues.apache.org/jira/browse/BROOKLYN-190
>             Project: Brooklyn
>          Issue Type: Improvement
>    Affects Versions: 0.8.0, 0.9.0
>            Reporter: Ciprian Ciubotariu
>            Assignee: Ciprian Ciubotariu
>            Priority: Minor
>             Fix For: 0.9.0
>
>
> According to [1] jetty9 is now the stable version.
> In relation to BROOKLYN-183, current stable pax-web 4.x series also support Jetty9 (although
I believe it can be used with Jetty8 as well). However, migrating Brooklyn to a more current
Jetty version seems preferable.
> [1] http://www.eclipse.org/jetty/documentation/current/what-jetty-version.html



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message