brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ciprian Ciubotariu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BROOKLYN-185) Upgrade swagger to 1.5.3
Date Tue, 20 Oct 2015 21:40:27 GMT

    [ https://issues.apache.org/jira/browse/BROOKLYN-185?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14965827#comment-14965827
] 

Ciprian Ciubotariu commented on BROOKLYN-185:
---------------------------------------------

I was looking by mistake at 1.3.12 at the time I wrote the description. swagger-1.5.x does
not depend on scala anymore, and it is provided as an OSGi bundle.

I will edit the description and remove the misleading comments. Apologies.

> Upgrade swagger to 1.5.3
> ------------------------
>
>                 Key: BROOKLYN-185
>                 URL: https://issues.apache.org/jira/browse/BROOKLYN-185
>             Project: Brooklyn
>          Issue Type: Improvement
>    Affects Versions: 0.8.0
>            Reporter: Ciprian Ciubotariu
>            Assignee: Ciprian Ciubotariu
>             Fix For: 0.9.0
>
>
> Brooklyn is now using swagger version 1.0.1, based on scala 2.9.1. The current stable
version is 1.5.3, based on scala 2.10/2.11, while version 1.0.1 is deprecated.
> More at https://github.com/swagger-api/swagger-core#compatibility
> Version 1.0.1 is a blocker for BROOKLYN-183, since both respective versions of swagger
and scala are not bundled for OSGi.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message