brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aled Sage (JIRA)" <j...@apache.org>
Subject [jira] [Created] (BROOKLYN-158) Brooklyn dependencyConvergence enforcer fails when run with cobertura-maven-plugin
Date Fri, 31 Jul 2015 14:16:04 GMT
Aled Sage created BROOKLYN-158:
----------------------------------

             Summary: Brooklyn dependencyConvergence enforcer fails when run with cobertura-maven-plugin
                 Key: BROOKLYN-158
                 URL: https://issues.apache.org/jira/browse/BROOKLYN-158
             Project: Brooklyn
          Issue Type: Bug
    Affects Versions: 0.8.0-SNAPSHOT
            Reporter: Aled Sage


When building Brooklyn with `mvn clean install -PCoverage`, it fails in the maven-enforcer-plugin
due to the dependencyConvergence rule.

The workaround is to comment out the dependencyConvergence rule in the maven-enforcer-plugin
plugin, in the parent/pom.xml.

The Coverage profile pulls in:

{noformat}
<dependency>
    <groupId>org.codehaus.mojo</groupId>
    <artifactId>cobertura-maven-plugin</artifactId>
    <version>${cobertura.plugin.version}</version>
    <scope>test</scope>
</dependency>
{noformat}

The error is things like that below (plus another couple of hundred lines of this).

{noformat}
[INFO] --- maven-enforcer-plugin:1.4:enforce (brooklyn-build-req) @ brooklyn-parent ---
[WARNING] 
Dependency convergence error for junit:junit:3.8.2 paths to dependency are:
+-org.apache.brooklyn:brooklyn-parent:0.8.0-SNAPSHOT
  +-org.codehaus.mojo:cobertura-maven-plugin:2.7
    +-net.sourceforge.cobertura:cobertura:2.1.1
      +-org.apache.ant:ant-junit:1.8.3
        +-junit:junit:3.8.2
and
+-org.apache.brooklyn:brooklyn-parent:0.8.0-SNAPSHOT
  +-org.codehaus.mojo:cobertura-maven-plugin:2.7
    +-net.sourceforge.cobertura:cobertura:2.1.1
      +-junit:junit:4.11
and
+-org.apache.brooklyn:brooklyn-parent:0.8.0-SNAPSHOT
  +-org.codehaus.mojo:cobertura-maven-plugin:2.7
    +-org.apache.maven:maven-core:2.0.8
      +-org.codehaus.plexus:plexus-container-default:1.0-alpha-9-stable-1
        +-junit:junit:3.8.1

[WARNING] 
Dependency convergence error for org.apache.maven:maven-project:2.0.8 paths to dependency
are:
+-org.apache.brooklyn:brooklyn-parent:0.8.0-SNAPSHOT
  +-org.codehaus.mojo:cobertura-maven-plugin:2.7
    +-org.apache.maven:maven-core:2.0.8
      +-org.apache.maven:maven-project:2.0.8
and
+-org.apache.brooklyn:brooklyn-parent:0.8.0-SNAPSHOT
  +-org.codehaus.mojo:cobertura-maven-plugin:2.7
    +-org.apache.maven:maven-project:2.0.8
and
+-org.apache.brooklyn:brooklyn-parent:0.8.0-SNAPSHOT
  +-org.codehaus.mojo:cobertura-maven-plugin:2.7
    +-org.apache.maven.reporting:maven-reporting-impl:2.0.4.2
      +-org.apache.maven:maven-project:2.0.4

[WARNING] 
Dependency convergence error for org.apache.maven.reporting:maven-reporting-api:2.0.8 paths
to dependency are:
+-org.apache.brooklyn:brooklyn-parent:0.8.0-SNAPSHOT
  +-org.codehaus.mojo:cobertura-maven-plugin:2.7
    +-org.apache.maven:maven-core:2.0.8
      +-org.apache.maven.reporting:maven-reporting-api:2.0.8
and
+-org.apache.brooklyn:brooklyn-parent:0.8.0-SNAPSHOT
  +-org.codehaus.mojo:cobertura-maven-plugin:2.7
    +-org.apache.maven.reporting:maven-reporting-api:2.0.8
and
+-org.apache.brooklyn:brooklyn-parent:0.8.0-SNAPSHOT
  +-org.codehaus.mojo:cobertura-maven-plugin:2.7
    +-org.apache.maven.reporting:maven-reporting-impl:2.0.4.2
      +-org.apache.maven.reporting:maven-reporting-api:2.0.4
{noformat}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message