brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Seybold <daniel.seyb...@uni-ulm.de>
Subject WebAppCluster with VanillaSoftwareProcess Parameters
Date Wed, 24 Jun 2015 09:46:44 GMT
Hi guys!

Wie tried to setup a ControlledDynamicWebAppCluster with a Ghost blog 
application, which we define as VanillaSoftwareProcess. As you see here:

We define the port of the Ghost server as follows:

   memberSpec:

     $brooklyn:entitySpec:

       - type: brooklyn.entity.basic.VanillaSoftwareProcess

         name: Simple Ghost Server

         id: ghost-server

         brooklyn.config:

           http.port: 2368

         env:

           DB_HOSTNAME: 
$brooklyn:component("sql-server").attributeWhenReady("host.name")

         launch.command: |

….

Unfortunately we still get this error and the Nginx remains unconfigured:

ERROR Unable to construct hostname:port representation for 
VanillaSoftwareProcessImpl{id=mHdfExDM} (131.0.1.131:null); skipping in 
NginxControllerImpl{id=IFdJgNft}

In the Nginx sensor it is stated that the pool consists of:

*{"VanillaSoftwareProcessImpl{id=i6yP6dNG}":null}*

Also there is defined that the port should be an object:

*member.sensor.portNumber 
{"typeToken":null,"type":"java.lang.Object","name":"http.port“…*

We also saw that in the case of Ghost (the VanillaSoftwareProcess) the 
declaration of the port ends up in being a String 
(http.port              2368 – only in the „Config“ section of the 
„Summary“ tab, NOT in the „Sensors“ tab, is this a problem?), whereas in 
the DynamicWebAppCluster the definition of the port ends up as object 
(http.port                {"port":2368} – also in the „Config“ section 
of the „Summary“ tab).

So lies the problem, that we can not define a correct port for the Nginx 
to be configured correctly, in the fact that a VanillaSoftwareProcess is 
not a WebApp? If so, how can we change the configuration of the 
VanillaSoftwareProcess or the NginxController to be configured 
correctly, without having to touch the source code, but only change the 
YAML blueprint?

Best regards

   Daniel

Mime
View raw message