brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hadrian Zbarcea <hzbar...@gmail.com>
Subject Re: Java 7 minimum?
Date Fri, 19 Jun 2015 11:47:21 GMT
+1.

Hadrian

On 06/08/2015 05:02 AM, Alex Heneveld wrote:
>
> Folks,
>
> Is there any objection to bumping the minimum Java version to 7 ?
>
> I'm not aware of anyone with a hard dependency on Java 6.  Although it
> has been sunsetted, it is still supported in production so I'll withdraw
> the suggestion if anyone needs it.  However working on TypeCoercion of
> string to date [1] I made heavy use of named-groups in regexes only to
> discover this is a 7-only feature.  It wouldn't be too hard to add
> jregex (or make flexible date-parsing a 7-only feature) but if no one
> needs Java 6 this feels like a good enough reason to change.
>
> (We'll need to update Jenkins to use Java 7 to build.)
>
> Best
> Alex
>
> [1]  https://github.com/apache/incubator-brooklyn/pull/682
>

Mime
View raw message