brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From neykov <...@git.apache.org>
Subject [GitHub] incubator-brooklyn pull request: Upgrade nginx addons
Date Tue, 26 May 2015 20:59:28 GMT
Github user neykov commented on a diff in the pull request:

    https://github.com/apache/incubator-brooklyn/pull/659#discussion_r31079195
  
    --- Diff: software/webapp/src/main/java/brooklyn/entity/proxy/nginx/NginxSshDriver.java
---
    @@ -216,6 +220,12 @@ public void install() {
             String withLdOpt = entity.getConfig(NginxController.WITH_LD_OPT);
             if (isMac) withLdOpt = format("-L%s/pcre-dist/lib", getInstallDir()) + (Strings.isBlank(withLdOpt)
? "" : " " + withLdOpt);
             String withCcOpt = entity.getConfig(NginxController.WITH_CC_OPT);
    +        
    +        if (isMac) {
    +            // TODO Upgrade sticky module as soon as a fix for https://bitbucket.org/nginx-goodies/nginx-sticky-module-ng/issue/16/can-not-compile-on-macosx-yosemite
    +            // is released and remove this block.
    +            withCcOpt = (Strings.isBlank(withCcOpt) ? "" : (withCcOpt + " ")) + "-Wno-error";
    --- End diff --
    
    The problem is just on mac. Wanted to have it applied even if the user supplies custom
`withCcOpt` value, making it compatible with existing blueprints.


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message