brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sjcorbett <...@git.apache.org>
Subject [GitHub] incubator-brooklyn pull request: Fixes RabbitMQ installation on Ce...
Date Thu, 05 Feb 2015 12:46:21 GMT
Github user sjcorbett commented on a diff in the pull request:

    https://github.com/apache/incubator-brooklyn/pull/503#discussion_r24160763
  
    --- Diff: software/messaging/src/main/java/brooklyn/entity/messaging/rabbit/RabbitSshDriver.java
---
    @@ -72,8 +80,15 @@ public void preInstall() {
         public void install() {
             List<String> urls = resolver.getTargets();
             String saveAs = resolver.getFilename();
    +        String osMajorVersion = Strings.nullToEmpty(getMachine().getOsDetails().getVersion());
    +        osMajorVersion = osMajorVersion.indexOf(".") > 0 ? osMajorVersion.substring(0,
osMajorVersion.indexOf('.')) : osMajorVersion;
    +        String epelVersion = Strings.nullToEmpty(CENTOS_VERSION_TO_EPEL_VERSION.get(osMajorVersion));
    +        String osArchitecture = Strings.nullToEmpty(getMachine().getOsDetails().getArch());
    --- End diff --
    
    Is this behaviour desirable? NPEs are guarded against but it could generate URLs like
`http://download.fedoraproject.org/pub/epel///epel-release-.noarch.rpm`. Should we pick a
default if we can't detect versions and architectures? Or it could even just fail.


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message