brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ahgittin <...@git.apache.org>
Subject [GitHub] incubator-brooklyn pull request: add maxmind v2 (now ASL licensed)...
Date Wed, 03 Sep 2014 14:41:21 GMT
Github user ahgittin commented on the pull request:

    https://github.com/apache/incubator-brooklyn/pull/142#issuecomment-54307305
  
    @aledsage good point, @richardcloudsoft this is actually a reasonably argument *against*
including when you are using a primary entry point to a dependency which exposes some of its
dependents.
    
    i don't know whether the Jackson we use is in `jackson-databind` or in one of its dependencies
e.g. `jackson-core`.  and i don't care -- `jackson-databind` encourages you to use things
from its core.  it seems counter-productive for me to attempt to track and redeclare the version
of `jackson-core`.
    
    i noticed this here because there is a version mismatch -- `jackson-databind 2.4.2` depends
on `jackson-core 2.4.0`.  that's maybe a minor bug on their side but it meant that we were
getting inconsistent versions of `jackson-core` since we explicitly declared `2.4.2` for all
`jackson` libs but we were not excluding the dependency declared by `jackson-databind`.


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message