brooklyn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Heneveld <alex.henev...@cloudsoftcorp.com>
Subject Re: Problems with running "My Web Cluster Blueprint" on OpenStack
Date Fri, 27 Jun 2014 11:30:01 GMT

Hi Stefan,

You can use this to keep failed VM's for post-mortems:

     brooklyn.location.named.MyOpenStack.destroyOnFailure=true

There is a debug log file which will report the IP address(es) it is 
trying to use.  Once the VM is up, can you also try SSH'ing and again 
confirm that this eventually works:

     ssh -i /path/to/your-keypair-name.pem ubuntu@IP

If there's a delay let us know how long that is.

A few other things:

* If you don't specify keypair, any privateKey, or 
openstack-nova.auto-generate-keypairs=false, it should normally work 
(assuming openstack is configured so it installs and reports keys 
correctly), and Brooklyn will default to the jclouds behaviour of 
creating a user, using your local username, and installing a new public 
key for use, using ~/.ssh/id_rsa.pub if that exists -- so you can then 
just   `ssh IP`

* waitForReachable timeout can use a human-readable syntax, e.g. "1h" 
(the default is 5m)

* Can you send the full stack trace?  I think this timeout is from 
jclouds testing ssh which is a slightly different pathway as when this 
timeout fails it gives a message "SSH failed for ..." .  But definitely 
confusing, we should try to fix.

Best
Alex


On 27/06/2014 11:59, Stefan Walraven wrote:
> Hi,
>
> I'm experimenting with brooklyn on a private OpenStack environment. 
> But the deployment fails when brooklyn tries to connect with the 
> created VMs. I saw there was another thread about this in the 
> beginning of this month, but the proposed solution doesn't work in my 
> case.
>
> Similar to the previous thread, the three VMs are launched, but then 
> it constantly fails when the brooklyn manager tries to ssh the VMs:
>
> java.util.NoSuchElementException: could not connect to any ip address 
> port 22 on node
>
>
> I have a keypair available in my OpenStack installation (added via web 
> console), and I specified in brooklyn.properties to use that keypair. 
> It effectively uses that one, but it still fails to login. Yesterday, 
> I tried to login myself to those VMs using SSH and it didn't work 
> immediately (there is some delay), but after a while I got in, so the 
> key pair is installed properly. However, I can't test this any more, 
> because now brooklyn immediately removes the VMs after failure (which 
> it didn't yesterday...).
>
> Anyway, I tried to solve this issue using the waitForSshable property, 
> but apparently this has no effect. The failure always occurs after the 
> same period of time (around 10 minutes after the process is started), 
> even if I put the waitForSshable property on 1 hour... My 
> brooklyn.properties looks as follows:
>
> brooklyn.location.named.MyOpenStack=< url >
>
> brooklyn.location.named.MyOpenStack.identity=<tenant name / user >
>
> brooklyn.location.named.MyOpenStack.credential=< password >
>
> brooklyn.location.named.MyOpenStack.imageId=<region / id>
>
> brooklyn.location.named.MyOpenStack.user=ubuntu
>
> brooklyn.location.named.MyOpenStack.keyPair=defaultkey
>
> brooklyn.location.named.MyOpenStack.securityGroups=brooklyn
>
> brooklyn.location.named.MyOpenStack.jclouds.openstack-nova.auto-create-floating-ips=false

>
>
> brooklyn.location.named.MyOpenStack.jclouds.openstack-nova.auto-generate-keypairs=false

>
>
> brooklyn.location.named.MyOpenStack.waitForSshable=3600000 # absurd 
> high number but no effect
>
> brooklyn.location.named.MyOpenStack.minRam=1024
>
>
> I tried the solution suggested in the previous thread, But this also 
> results in the same issue:
>
> brooklyn.location.jclouds.my-openstack.keyPair=your-keypair-name
>
> brooklyn.location.jclouds.my-openstack.loginUser.privateKeyFile=/path/to/your-keypair-name.pem

>
>
>
> Furthermore, I tried to upload my keys via brooklyn, but then I don't 
> get a key pair (similar to the previous thread). That only works when 
> using the keyPair property, but this requires the key pair to be 
> already available in the OpenStack installation (as far as I 
> experienced).
>
> I hope someone can help me to solve this issue.
>
> Thanks in advance,
> Stefan Walraven
>
> Disclaimer: http://www.kuleuven.be/cwis/email_disclaimer.htm


Mime
View raw message