brooklyn-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From tbou...@apache.org
Subject [2/5] brooklyn-server git commit: fix maven dependecies
Date Wed, 11 Apr 2018 13:40:55 GMT
fix maven dependecies


Project: http://git-wip-us.apache.org/repos/asf/brooklyn-server/repo
Commit: http://git-wip-us.apache.org/repos/asf/brooklyn-server/commit/02b457d4
Tree: http://git-wip-us.apache.org/repos/asf/brooklyn-server/tree/02b457d4
Diff: http://git-wip-us.apache.org/repos/asf/brooklyn-server/diff/02b457d4

Branch: refs/heads/master
Commit: 02b457d41a624d3f4bae53a61a9dcc72e5424bb7
Parents: 6ddc595
Author: andreaturli <andrea.turli@gmail.com>
Authored: Mon Mar 12 21:11:33 2018 +0100
Committer: andreaturli <andrea.turli@gmail.com>
Committed: Mon Mar 12 21:11:33 2018 +0100

----------------------------------------------------------------------
 locations/container/pom.xml | 41 ----------------------------------------
 1 file changed, 41 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/brooklyn-server/blob/02b457d4/locations/container/pom.xml
----------------------------------------------------------------------
diff --git a/locations/container/pom.xml b/locations/container/pom.xml
index da1434b..56f0bf4 100644
--- a/locations/container/pom.xml
+++ b/locations/container/pom.xml
@@ -55,13 +55,6 @@
                 </exclusion>
             </exclusions>
         </dependency>
-
-
-        <dependency>
-            <groupId>com.google.errorprone</groupId>
-            <artifactId>error_prone_annotations</artifactId>
-            <version>2.0.19</version>
-        </dependency>
         <dependency>
             <groupId>io.grpc</groupId>
             <artifactId>grpc-context</artifactId>
@@ -86,28 +79,6 @@
             <version>${kubernetes-client.version}</version>
             <classifier>bundle</classifier>
         </dependency>
-
-        <!--
-            Expect Brooklyn to exclude this, and to choose its own jclouds-docker version.
-            So if this version is not kept up-to-date then it won't impact Brooklyn.
-        -->
-        <dependency>
-            <groupId>${jclouds.groupId}.api</groupId>
-            <artifactId>docker</artifactId>
-            <version>${jclouds.version}</version>
-            <exclusions>
-                <exclusion>
-                    <!-- Conflicts with javax.ws.rs-api -->
-                    <groupId>javax.ws.rs</groupId>
-                    <artifactId>jsr311-api</artifactId>
-                </exclusion>
-                <exclusion>
-                    <groupId>com.squareup.okio</groupId>
-                    <artifactId>okio</artifactId>
-                </exclusion>
-            </exclusions>
-        </dependency>
-
         <dependency>
             <groupId>org.apache.brooklyn</groupId>
             <artifactId>brooklyn-core</artifactId>
@@ -124,18 +95,6 @@
             <groupId>org.apache.brooklyn</groupId>
             <artifactId>brooklyn-locations-jclouds</artifactId>
             <version>${brooklyn.version}</version>
-            <exclusions>
-                <exclusion>
-                    <groupId>com.squareup.okio</groupId>
-                    <artifactId>okio</artifactId>
-                </exclusion>
-            </exclusions>
-        </dependency>
-
-        <dependency>
-            <groupId>com.squareup.okio</groupId>
-            <artifactId>okio</artifactId>
-            <version>1.13.0</version>
         </dependency>
 
         <dependency>


Mime
View raw message