brooklyn-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rich...@apache.org
Subject [3/3] brooklyn-library git commit: Specify Java version for JBoss
Date Tue, 18 Apr 2017 12:41:05 GMT
Specify Java version for JBoss

(cherry picked from commit e8c7b9e9baf6d2f9c58cd5ef52d2821721c4d24f)


Project: http://git-wip-us.apache.org/repos/asf/brooklyn-library/repo
Commit: http://git-wip-us.apache.org/repos/asf/brooklyn-library/commit/c20857da
Tree: http://git-wip-us.apache.org/repos/asf/brooklyn-library/tree/c20857da
Diff: http://git-wip-us.apache.org/repos/asf/brooklyn-library/diff/c20857da

Branch: refs/heads/0.11.x
Commit: c20857da53728b882117ab4e3d3613f13c27ca21
Parents: 52962b0
Author: Duncan Godwin <duncan.godwin@cloudsoftcorp.com>
Authored: Fri Apr 14 13:23:48 2017 +0100
Committer: Richard Downer <richard@apache.org>
Committed: Tue Apr 18 13:40:16 2017 +0100

----------------------------------------------------------------------
 .../apache/brooklyn/entity/webapp/jboss/JBoss6SshDriver.java | 8 ++++++++
 .../apache/brooklyn/entity/webapp/jboss/JBoss7SshDriver.java | 8 ++++++++
 2 files changed, 16 insertions(+)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/brooklyn-library/blob/c20857da/software/webapp/src/main/java/org/apache/brooklyn/entity/webapp/jboss/JBoss6SshDriver.java
----------------------------------------------------------------------
diff --git a/software/webapp/src/main/java/org/apache/brooklyn/entity/webapp/jboss/JBoss6SshDriver.java
b/software/webapp/src/main/java/org/apache/brooklyn/entity/webapp/jboss/JBoss6SshDriver.java
index 70d6a14..1426f5b 100644
--- a/software/webapp/src/main/java/org/apache/brooklyn/entity/webapp/jboss/JBoss6SshDriver.java
+++ b/software/webapp/src/main/java/org/apache/brooklyn/entity/webapp/jboss/JBoss6SshDriver.java
@@ -90,6 +90,14 @@ public class JBoss6SshDriver extends JavaWebAppSshDriver implements JBoss6Driver
     }
 
     @Override
+    public boolean installJava() {
+        /*
+         * JBoss only works on Java 7 or lower, see here: https://developer.jboss.org/message/808212
+         */
+        return checkForAndInstallJava("1.7");
+    }
+
+    @Override
     public void install() {
         List<String> urls = resolver.getTargets();
         String saveAs = resolver.getFilename();

http://git-wip-us.apache.org/repos/asf/brooklyn-library/blob/c20857da/software/webapp/src/main/java/org/apache/brooklyn/entity/webapp/jboss/JBoss7SshDriver.java
----------------------------------------------------------------------
diff --git a/software/webapp/src/main/java/org/apache/brooklyn/entity/webapp/jboss/JBoss7SshDriver.java
b/software/webapp/src/main/java/org/apache/brooklyn/entity/webapp/jboss/JBoss7SshDriver.java
index 8a40947..5812f3a 100644
--- a/software/webapp/src/main/java/org/apache/brooklyn/entity/webapp/jboss/JBoss7SshDriver.java
+++ b/software/webapp/src/main/java/org/apache/brooklyn/entity/webapp/jboss/JBoss7SshDriver.java
@@ -110,6 +110,14 @@ public class JBoss7SshDriver extends JavaWebAppSshDriver implements JBoss7Driver
     }
 
     @Override
+    public boolean installJava() {
+        /*
+         * JBoss only works on Java 7 or lower, see here: https://developer.jboss.org/message/808212
+         */
+        return checkForAndInstallJava("1.7");
+    }
+
+    @Override
     public void install() {
         List<String> urls = resolver.getTargets();
         String saveAs = resolver.getFilename();


Mime
View raw message