brooklyn-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From henev...@apache.org
Subject [09/10] incubator-brooklyn git commit: set all java refs in docs to 1.7+
Date Mon, 15 Jun 2015 07:41:33 GMT
set all java refs in docs to 1.7+


Project: http://git-wip-us.apache.org/repos/asf/incubator-brooklyn/repo
Commit: http://git-wip-us.apache.org/repos/asf/incubator-brooklyn/commit/449f2007
Tree: http://git-wip-us.apache.org/repos/asf/incubator-brooklyn/tree/449f2007
Diff: http://git-wip-us.apache.org/repos/asf/incubator-brooklyn/diff/449f2007

Branch: refs/heads/master
Commit: 449f200754939595c9731d499c1f73058ae956ef
Parents: aa82c62
Author: Alex Heneveld <alex.heneveld@cloudsoftcorp.com>
Authored: Mon Jun 15 08:36:32 2015 +0100
Committer: Alex Heneveld <alex.heneveld@cloudsoftcorp.com>
Committed: Mon Jun 15 08:36:32 2015 +0100

----------------------------------------------------------------------
 docs/guide/dev/env/ide/index.md   | 11 ++++-------
 docs/guide/dev/env/maven-build.md |  2 +-
 docs/guide/ops/requirements.md    |  2 +-
 docs/guide/start/running.md       |  2 +-
 4 files changed, 7 insertions(+), 10 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/incubator-brooklyn/blob/449f2007/docs/guide/dev/env/ide/index.md
----------------------------------------------------------------------
diff --git a/docs/guide/dev/env/ide/index.md b/docs/guide/dev/env/ide/index.md
index 0dddfc1..f046abc 100644
--- a/docs/guide/dev/env/ide/index.md
+++ b/docs/guide/dev/env/ide/index.md
@@ -87,14 +87,11 @@ To develop or debug Brooklyn in IntelliJ, you will need to ensure that
the Groov
 via the IntelliJ IDEA | Preferences | Plugins menu. Once installed, you can open Brooklyn
from the root folder, 
 (e.g. ``~/myfiles/brooklyn``) which will automatically open the subprojects.
 
+You will need the java compiler 1.7 or higher.
 There have previously been issues where the java 6 compiler incorrectly identified the return
type of functions that use
-generics. These issues have been refactored away, however may return in future. If so, you
can either set the java compiler
-level to 1.7, or setup IntelliJ to use the Eclipse compiler as per the instructions provided
by JetBeans:
-
-> The problem seems to be caused by bug in java compiler from JDK 1.6, it is known to
sometimes produce compilation 
-> errors for complicated code involving generic types. Java compiler from JDK 1.7 compiles
your code successfully so I would 
-> recommend you to consider upgrading to JDK 1.7. If it isn't possible you can switch
to Eclipse Compiler (Settings | 
-> Compiler | Java Compiler | "Use Compiler" combobox).
+generics. These issues have been refactored away, however may return in future. 
+If you encounter these problems, ensure that your java compiler is set to level 1.7 or higher,

+or setup IntelliJ to use the Eclipse compiler (Settings | Compiler | Java Compiler | "Use
Compiler" combobox).
 
 
 ## Netbeans

http://git-wip-us.apache.org/repos/asf/incubator-brooklyn/blob/449f2007/docs/guide/dev/env/maven-build.md
----------------------------------------------------------------------
diff --git a/docs/guide/dev/env/maven-build.md b/docs/guide/dev/env/maven-build.md
index 1448f1f..fa0895b8 100644
--- a/docs/guide/dev/env/maven-build.md
+++ b/docs/guide/dev/env/maven-build.md
@@ -6,7 +6,7 @@ toc: /guide/toc.json
 
 ## The Basics
 
-To build the code, you need Maven (v3) installed and Java (1.6).
+To build the code, you need Maven (v3) installed and Java (v1.7+).
 With that in place, you should be able to build everything with a:
 
 {% highlight bash %}

http://git-wip-us.apache.org/repos/asf/incubator-brooklyn/blob/449f2007/docs/guide/ops/requirements.md
----------------------------------------------------------------------
diff --git a/docs/guide/ops/requirements.md b/docs/guide/ops/requirements.md
index d0cf7fd..b23fdd3 100644
--- a/docs/guide/ops/requirements.md
+++ b/docs/guide/ops/requirements.md
@@ -28,7 +28,7 @@ Brooklyn has also been tested on Ubuntu 12.04 and OS X.
 
 ## Software Requirements
 
-Brooklyn requires Java (JRE or JDK) minimum version 7. 
+Brooklyn requires Java (JRE or JDK) minimum version 1.7. 
 OpenJDK is recommended. Brooklyn has also been tested on IBM J9 and Oracle's JVM.
 
 

http://git-wip-us.apache.org/repos/asf/incubator-brooklyn/blob/449f2007/docs/guide/start/running.md
----------------------------------------------------------------------
diff --git a/docs/guide/start/running.md b/docs/guide/start/running.md
index a5c8e06..b6f1a48 100644
--- a/docs/guide/start/running.md
+++ b/docs/guide/start/running.md
@@ -31,7 +31,7 @@ $ tar -zxf brooklyn-{{ site.brooklyn-version }}-dist.tar.gz
 
 This will create a `brooklyn-{{ site.brooklyn-version }}` folder.
 
-**Note**: You'll need a Java JRE or SDK installed (version 6 or later), as Brooklyn is Java
under the covers.
+**Note**: You'll need a Java JRE or SDK installed (version 1.7 or later), as Brooklyn is
Java under the covers.
 
 **Node #2**: If you want to test Brooklyn on localhost, follow [these instructions]({{site.path.guide}}/ops/locations/#localhost)

 to ensure that your Brooklyn can access your machine.


Mime
View raw message