brooklyn-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From henev...@apache.org
Subject [32/50] [abbrv] incubator-brooklyn git commit: update Gemfile and move to root
Date Wed, 17 Dec 2014 17:24:06 GMT
update Gemfile and move to root


Project: http://git-wip-us.apache.org/repos/asf/incubator-brooklyn/repo
Commit: http://git-wip-us.apache.org/repos/asf/incubator-brooklyn/commit/19d29158
Tree: http://git-wip-us.apache.org/repos/asf/incubator-brooklyn/tree/19d29158
Diff: http://git-wip-us.apache.org/repos/asf/incubator-brooklyn/diff/19d29158

Branch: refs/heads/master
Commit: 19d29158103598eb029bd7fb0bfa5b8f485545d0
Parents: be3bdd7
Author: Alex Heneveld <alex.heneveld@cloudsoftcorp.com>
Authored: Wed Dec 17 00:37:45 2014 +0000
Committer: Alex Heneveld <alex.heneveld@cloudsoftcorp.com>
Committed: Wed Dec 17 02:02:57 2014 +0000

----------------------------------------------------------------------
 docs/Gemfile                                 |  9 +++
 docs/Gemfile.lock                            | 91 +++++++++++++++++++++++
 docs/README.md                               | 43 +++++------
 docs/_build/Gemfile                          | 26 -------
 docs/_build/Gemfile.lock                     | 32 --------
 docs/_build/config-exclude-all-but-guide.yml |  2 +-
 docs/_build/config-exclude-guide.yml         |  2 +-
 docs/_config.yml                             | 10 +--
 8 files changed, 129 insertions(+), 86 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/incubator-brooklyn/blob/19d29158/docs/Gemfile
----------------------------------------------------------------------
diff --git a/docs/Gemfile b/docs/Gemfile
new file mode 100644
index 0000000..aacd3c9
--- /dev/null
+++ b/docs/Gemfile
@@ -0,0 +1,9 @@
+#ruby=ruby-2.1.2
+#ruby-gemset=incubator-brooklyn-site
+
+source 'https://rubygems.org'
+
+gem 'jekyll'
+gem 'therubyracer'
+gem 'link-checker'
+gem 'json'

http://git-wip-us.apache.org/repos/asf/incubator-brooklyn/blob/19d29158/docs/Gemfile.lock
----------------------------------------------------------------------
diff --git a/docs/Gemfile.lock b/docs/Gemfile.lock
new file mode 100644
index 0000000..ada2724
--- /dev/null
+++ b/docs/Gemfile.lock
@@ -0,0 +1,91 @@
+GEM
+  remote: https://rubygems.org/
+  specs:
+    anemone (0.7.2)
+      nokogiri (>= 1.3.0)
+      robotex (>= 1.0.0)
+    blankslate (2.1.2.4)
+    celluloid (0.16.0)
+      timers (~> 4.0.0)
+    classifier-reborn (2.0.2)
+      fast-stemmer (~> 1.0)
+    coffee-script (2.3.0)
+      coffee-script-source
+      execjs
+    coffee-script-source (1.8.0)
+    colorator (0.1)
+    colorize (0.5.8)
+    execjs (2.2.2)
+    fast-stemmer (1.0.2)
+    ffi (1.9.6)
+    hitimes (1.2.2)
+    jekyll (2.5.2)
+      classifier-reborn (~> 2.0)
+      colorator (~> 0.1)
+      jekyll-coffeescript (~> 1.0)
+      jekyll-gist (~> 1.0)
+      jekyll-paginate (~> 1.0)
+      jekyll-sass-converter (~> 1.0)
+      jekyll-watch (~> 1.1)
+      kramdown (~> 1.3)
+      liquid (~> 2.6.1)
+      mercenary (~> 0.3.3)
+      pygments.rb (~> 0.6.0)
+      redcarpet (~> 3.1)
+      safe_yaml (~> 1.0)
+      toml (~> 0.1.0)
+    jekyll-coffeescript (1.0.1)
+      coffee-script (~> 2.2)
+    jekyll-gist (1.1.0)
+    jekyll-paginate (1.1.0)
+    jekyll-sass-converter (1.3.0)
+      sass (~> 3.2)
+    jekyll-watch (1.2.0)
+      listen (~> 2.7)
+    json (1.8.1)
+    kramdown (1.5.0)
+    libv8 (3.16.14.7)
+    link-checker (0.7.2)
+      anemone (~> 0.7.2)
+      colorize (~> 0.5.8)
+      nokogiri (~> 1.5.5)
+      trollop (~> 2.0)
+    liquid (2.6.1)
+    listen (2.8.3)
+      celluloid (>= 0.15.2)
+      rb-fsevent (>= 0.9.3)
+      rb-inotify (>= 0.9)
+    mercenary (0.3.5)
+    nokogiri (1.5.11)
+    parslet (1.5.0)
+      blankslate (~> 2.0)
+    posix-spawn (0.3.8)
+    pygments.rb (0.6.0)
+      posix-spawn (~> 0.3.6)
+      yajl-ruby (~> 1.1.0)
+    rb-fsevent (0.9.4)
+    rb-inotify (0.9.5)
+      ffi (>= 0.5.0)
+    redcarpet (3.2.2)
+    ref (1.0.5)
+    robotex (1.0.0)
+    safe_yaml (1.0.4)
+    sass (3.4.9)
+    therubyracer (0.12.1)
+      libv8 (~> 3.16.14.0)
+      ref
+    timers (4.0.1)
+      hitimes
+    toml (0.1.2)
+      parslet (~> 1.5.0)
+    trollop (2.0)
+    yajl-ruby (1.1.0)
+
+PLATFORMS
+  ruby
+
+DEPENDENCIES
+  jekyll
+  json
+  link-checker
+  therubyracer

http://git-wip-us.apache.org/repos/asf/incubator-brooklyn/blob/19d29158/docs/README.md
----------------------------------------------------------------------
diff --git a/docs/README.md b/docs/README.md
index b7ab49b..b090785 100644
--- a/docs/README.md
+++ b/docs/README.md
@@ -21,43 +21,44 @@ Workstation Setup
 First, if you have not already done so, clone the `incubator-brooklyn` repository 
 and set up the remotes as described in [Guide for committers][COMMIT].
 
-Install [RVM](http://rvm.io/); this manages Ruby installations and sets of Ruby
-gems.
+The Brooklyn documentation uses Markdown notation (what this file is written in)
+and the Jekyll process. This in turn requires Ruby and gems as described in the `Gemfile`:
+install [RVM](http://rvm.io/) to manage Ruby installations and sets of Ruby gems.
 
     \curl -sSL https://get.rvm.io | bash -s stable
 
-At this point, close your shell session and start a new one, to get the new
-environment that RVM has configured. Now change directory to the location where
-you checked out your repository, and then to the `docs/_build` subdirectory.
+Close your shell session and start a new one, to get the new
+environment that RVM has configured. Change directory to the location where
+you checked out your repository and then to the `docs/` subdirectory (where this file is
located).
 
 RVM should detect its configuration inside `Gemfile` and try to configure itself. 
-Most likely it will report that the required version of Ruby is not installed; 
-it will show the command that you need to run to install the correct version. 
-Follow these instructions.
+Most likely it will report that the required version of Ruby is not installed,
+and it will show the command that you need to run to install the correct version. 
+Follow the instructions it shows.
 
 Once the correct version of Ruby is installed, change to your home directory
-(`cd ~`) and then change back to the `_build` dir again (`cd -`). This will cause
-RVM to re-load configuration from `Gemfile` with the correct version of Ruby.
+and then change back (`cd ~ ; cd -`).
+This will cause RVM to re-load configuration from `Gemfile` with the correct version of Ruby.
 
-If you are running Ubuntu, there is a further dependency that is required:
-
-    sudo apt-get install libxslt-dev libxml2-dev
-
-Finally, run this command inside `_build` to install all the required Gems 
+Finally, run this command to install all the required Gems 
 at the correct versions:
 
     bundle install
 
-Any time you need to reset your Ruby environment for jekyll to run correctly,
+Any time you need to reset your Ruby environment for `jekyll` to run correctly,
 return to the `_build` directory and re-run the above command.
 
+On some platforms there may be some fiddling required before `jekyll` runs without errors,
+but the ecosystem is fairly mature and most problems can be resolved with a bit of googling.
+For instance on Ubuntu, there may be additional dependencies required:
+
+    sudo apt-get install libxslt-dev libxml2-dev
 
-Building and Previewing the Website
------------------------------------
 
-### Using Jekyll's in-built server
+Seeing the Website and Docs
+---------------------------
 
-In the `docs` directory, run the command:
+To build and see the documentation, run this command in your `docs` folder:
 
     jekyll serve --watch
     
@@ -65,7 +66,7 @@ This will start up a local web server. The URL is printed by Jekyll when
the ser
 e.g. http://localhost:4000/ . The server will continue to run until you press Ctrl+C.
 Modified files will be detected and regenerated (but that might take up to 1m).
 Leave off the `--watch` argument to turn off regeneration, or use `jekyll build` instead
-to generate a site in `_site` without a server, for instance if your browser supports running
from disk.
+to generate a site in `_site` without a server.
 
 
 Project Structure

http://git-wip-us.apache.org/repos/asf/incubator-brooklyn/blob/19d29158/docs/_build/Gemfile
----------------------------------------------------------------------
diff --git a/docs/_build/Gemfile b/docs/_build/Gemfile
deleted file mode 100644
index 99a2d5a..0000000
--- a/docs/_build/Gemfile
+++ /dev/null
@@ -1,26 +0,0 @@
-#
-# Licensed to the Apache Software Foundation (ASF) under one
-# or more contributor license agreements.  See the NOTICE file
-# distributed with this work for additional information
-# regarding copyright ownership.  The ASF licenses this file
-# to you under the Apache License, Version 2.0 (the
-# "License"); you may not use this file except in compliance
-# with the License.  You may obtain a copy of the License at
-#
-#  http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing,
-# software distributed under the License is distributed on an
-# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
-# KIND, either express or implied.  See the License for the
-# specific language governing permissions and limitations
-# under the License.
-#
-
-#ruby=ruby-2.1.2
-#ruby-gemset=brooklyn-docs
-
-source 'https://rubygems.org'
-gem 'jekyll', '~>0'
-gem 'json'
-gem 'rdiscount'

http://git-wip-us.apache.org/repos/asf/incubator-brooklyn/blob/19d29158/docs/_build/Gemfile.lock
----------------------------------------------------------------------
diff --git a/docs/_build/Gemfile.lock b/docs/_build/Gemfile.lock
deleted file mode 100644
index f5fd450..0000000
--- a/docs/_build/Gemfile.lock
+++ /dev/null
@@ -1,32 +0,0 @@
-GEM
-  remote: https://rubygems.org/
-  specs:
-    classifier (1.3.4)
-      fast-stemmer (>= 1.0.0)
-    directory_watcher (1.5.1)
-    fast-stemmer (1.0.2)
-    jekyll (0.12.1)
-      classifier (~> 1.3)
-      directory_watcher (~> 1.1)
-      kramdown (~> 0.14)
-      liquid (~> 2.3)
-      maruku (~> 0.5)
-      pygments.rb (~> 0.3.2)
-    json (1.8.1)
-    kramdown (0.14.2)
-    liquid (2.6.1)
-    maruku (0.7.1)
-    posix-spawn (0.3.8)
-    pygments.rb (0.3.7)
-      posix-spawn (~> 0.3.6)
-      yajl-ruby (~> 1.1.0)
-    rdiscount (2.1.7.1)
-    yajl-ruby (1.1.0)
-
-PLATFORMS
-  ruby
-
-DEPENDENCIES
-  jekyll (~> 0)
-  json
-  rdiscount

http://git-wip-us.apache.org/repos/asf/incubator-brooklyn/blob/19d29158/docs/_build/config-exclude-all-but-guide.yml
----------------------------------------------------------------------
diff --git a/docs/_build/config-exclude-all-but-guide.yml b/docs/_build/config-exclude-all-but-guide.yml
index 7ed3c5a..8acf536 100644
--- a/docs/_build/config-exclude-all-but-guide.yml
+++ b/docs/_build/config-exclude-all-but-guide.yml
@@ -1 +1 @@
-exclude: ['/LICENSE.txt','/README.md','/index.md','/favicon.ico','/website']
\ No newline at end of file
+exclude: ['/Gemfile*','/README.md','/index.md','/website']

http://git-wip-us.apache.org/repos/asf/incubator-brooklyn/blob/19d29158/docs/_build/config-exclude-guide.yml
----------------------------------------------------------------------
diff --git a/docs/_build/config-exclude-guide.yml b/docs/_build/config-exclude-guide.yml
index 373dc76..a4ad1c9 100644
--- a/docs/_build/config-exclude-guide.yml
+++ b/docs/_build/config-exclude-guide.yml
@@ -1 +1 @@
-exclude: ['/LICENSE.txt','/README.md','/guide']
\ No newline at end of file
+exclude: ['/Gemfile*','/README.md','/guide']

http://git-wip-us.apache.org/repos/asf/incubator-brooklyn/blob/19d29158/docs/_config.yml
----------------------------------------------------------------------
diff --git a/docs/_config.yml b/docs/_config.yml
index ec8af31..7086d35 100644
--- a/docs/_config.yml
+++ b/docs/_config.yml
@@ -16,11 +16,8 @@
 # specific language governing permissions and limitations
 # under the License.
 #
-exclude: [ LICENSE.txt ]
-encoding: utf-8
 
-brooklyn-version: 0.7.0-SNAPSHOT # BROOKLYN_VERSION
-brooklyn-snapshot-git-branch: master   # if line above is SNAPSHOT this should point to corresponding
git branch (e.g. master, 0.4)
+encoding: utf-8
 
 # where this will publish
 url_root: http://0.0.0.0:4000
@@ -40,5 +37,8 @@ dependency_urls:
   jquery.js: https://ajax.googleapis.com/ajax/libs/jquery/2.1.1/jquery.min.js
 
 # These files should not be included in the final build (in addition to _* contents)
-exclude: ['/LICENSE.txt','/README.md']
+exclude: ['/Gemfile*','/README.md']
+
+brooklyn-version: 0.7.0-SNAPSHOT # BROOKLYN_VERSION
+brooklyn-snapshot-git-branch: master   # if line above is SNAPSHOT this should point to corresponding
git branch (e.g. master, 0.4)
 


Mime
View raw message