brooklyn-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From henev...@apache.org
Subject [09/11] git commit: Installs python-httplib2 (required when running on docker container)
Date Mon, 01 Sep 2014 16:55:40 GMT
Installs python-httplib2 (required when running on docker container)


Project: http://git-wip-us.apache.org/repos/asf/incubator-brooklyn/repo
Commit: http://git-wip-us.apache.org/repos/asf/incubator-brooklyn/commit/ea8283ef
Tree: http://git-wip-us.apache.org/repos/asf/incubator-brooklyn/tree/ea8283ef
Diff: http://git-wip-us.apache.org/repos/asf/incubator-brooklyn/diff/ea8283ef

Branch: refs/heads/master
Commit: ea8283efde743fc7497a86c27acc4bb1dbe5739a
Parents: 92672c4
Author: Martin Harris <github@nakomis.com>
Authored: Mon Sep 1 17:37:29 2014 +0100
Committer: Martin Harris <github@nakomis.com>
Committed: Mon Sep 1 17:37:29 2014 +0100

----------------------------------------------------------------------
 .../brooklyn/entity/nosql/couchbase/CouchbaseNodeSshDriver.java    | 2 ++
 1 file changed, 2 insertions(+)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/incubator-brooklyn/blob/ea8283ef/software/nosql/src/main/java/brooklyn/entity/nosql/couchbase/CouchbaseNodeSshDriver.java
----------------------------------------------------------------------
diff --git a/software/nosql/src/main/java/brooklyn/entity/nosql/couchbase/CouchbaseNodeSshDriver.java
b/software/nosql/src/main/java/brooklyn/entity/nosql/couchbase/CouchbaseNodeSshDriver.java
index 3269aad..56a8623 100644
--- a/software/nosql/src/main/java/brooklyn/entity/nosql/couchbase/CouchbaseNodeSshDriver.java
+++ b/software/nosql/src/main/java/brooklyn/entity/nosql/couchbase/CouchbaseNodeSshDriver.java
@@ -101,6 +101,8 @@ public class CouchbaseNodeSshDriver extends AbstractSoftwareProcessSshDriver
imp
                 "export DEBIAN_FRONTEND=noninteractive",
                 "which apt-get",
                 sudo("apt-get update"),
+                // The following line is required to run on Docker container
+                sudo("apt-get install -y python-httplib2"),
                 sudo("apt-get install -y libssl0.9.8"),
                 sudo(format("dpkg -i %s", saveAs)));
 


Mime
View raw message