bloodhound-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ryan J Ollos <rjol...@apache.org>
Subject Re: PostgreSQL IntegrityError upgrading BH from v0.5 to v0.8
Date Mon, 23 Mar 2015 19:44:27 GMT
On Thu, Mar 19, 2015 at 6:43 AM, Vijay Varadan <vijay@axham.com> wrote:

> Hello,
>
> I've been trying to upgrade Bloodhound from v0.5 to v0.8. I also tried
> upgrading from v0.5 to v0.7 and get the same error below. I followed the
> instructions at
> https://issues.apache.org/bloodhound/wiki/BloodhoundUpgrade.
> The version of PostgreSQL I'm using is 9.1.5 and I'm running on Ubuntu
> 12.04
> with Python 2.7.3.
>
> Error I get:
> ============
>
> (bloodhound)root@vcs01:/srv/webapps/bloodhound# trac-admin
> apache-bloodhound/installer/bloodhound/environments/knack upgrade
> The upgrade failed. Please fix the issue and try again.
>
> IntegrityError: duplicate key value violates unique constraint
> "permission_pk"
> DETAIL:  Key (username, action, product)=(authenticated, PRODUCT_VIEW, art)
> already exists.
>
> I've checked trac mailing list archives and BH mailing list archives as
> well
> as tickets in BH, but I wasn't able to find any solution.
>
> Does anyone know how to get past this?
>
> Thanks,
> Vijay
> p.s. I tried to find BH v0.6 to try and upgrade to, but it's not available
> anywhere.
>

I'll need to look at the upgrade scripts to be sure, but my first thought
is that you should just try revoking PRODUCT_VIEW from the authenticated
meta-group before running the upgrade again.

Mime
View raw message