bloodhound-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arthur Kahlich <...@millcomputing.com>
Subject There is an error or omission in the Apache conf example
Date Tue, 16 Dec 2014 05:20:13 GMT
Hi,

I am sending this as a potential tweak to the installation instructions at

https://issues.apache.org/bloodhound/wiki/BloodhoundInstall#WebServer

On the example <VirtualHost...> xml code, the second line given as:

WSGIDaemonProcess bh_tracker user=bloodhound
python-path=/opt/bloodhound/bhenv/lib/python2.7/site-packages

There should be some note for those like me who can stare at something
for a while and not see what is wrong.  In fact, if I had python 2.7
installed on my machine, this line would have worked perfectly - but I
did not.  Instead, I had what comes on CentOS 6.5: Python 2.6.  I work
on a variety of machines, some of which have python 2.7, so I am not
inclined to notice this. What I saw when I tried to access this was the
following in my Apache ssl_error_log file:

[...] [error] [client foo] mod_wsgi (pid=27220): Exception occurred
processing WSGI script
'/opt/bloodhound/environments/main/site/cgi-bin/trac.wsgi'.
[...] [error] [client foo] Traceback (most recent call last):
[...] [error] [client foo]   File
"/opt/bloodhound/environments/main/site/cgi-bin/trac.wsgi", line 31, in
application
[...] [error] [client foo]     from trac.web import dispatch_request
[...] [error] [client foo] ImportError: No module named trac.web

Which when I finally determined the 'python-path' to be indicating a
non-existent path on my machine this made sense - but not before!

So for me, the second line in the <VirtualHost...> xml code needed to be:

WSGIDaemonProcess bh_tracker user=bloodhound
python-path=/opt/bloodhound/bhenv/lib/python2.6/site-packages

and suddenly all is working.

-- 
Arthur Kahlich
CTO - Hardware
Mill Computing, Inc.
Box 1531
Palo Alto CA 94302-1531
Phone: (408)480-3680
--
Faster, Cooler, Safer Computing.
--


Mime
View raw message