bloodhound-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ryan J Ollos <rjol...@apache.org>
Subject Re: Is there a minimum subversion version requirement?
Date Thu, 11 Sep 2014 06:22:56 GMT
On Wed, Sep 10, 2014 at 10:51 PM, Arthur Kahlich <art@millcomputing.com>
wrote:

> I am attempting to setup apache-bloodhound-0.7 on a Centos release 6.5
> (Final) machine.
> I am following the instructions to setup bloodhound with subversion at:
>
> https://issues.apache.org/bloodhound/wiki/BloodhoundInstall#Subversion
>
> I have added the epel-release repository to my install, so I have installed
>
> Python 2.6.6
> svn, version 1.6.11 (r934486)
>
> If I do
>
> yum search python-subversion
>
> it finds nothing.
>
> Do I need to have subversion 1.7 or later?
> Do I need to go to:
>
> http://opensource.wandisco.com/rhel/6/svn-1.7/RPMS/x86_64/
>
> and get the latest?
> Are the 'subversion-python' rpm's there what are used now with a
> bloodhound install?
>
> Thanks for your help!
> Art
>
> PS: This subversion 1.6.11 worked with Trac 0.12 as installed using the
> Centos 6 rpm repositories, but I wanted the multiple product capability
> that bloodhound offers.


Trac 1.0.x supports Subversion 1.6, so Subversion 1.6 should work with
Bloodhound as well. I guess your question is how to get the
python-subversion bindings on CentOS 6.5? I was, perhaps naively, expecting
that all major Linux distributions would provide the python-subversion
package. I did some quick reading and couldn't find an easy answer;
building the bindings from source seems complex. It seems like the quickest
fix may be to install the WANdisco package simply because they provide the
Subversion bindings as well.

Mime
View raw message