bloodhound-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olemis Lang <ole...@gmail.com>
Subject Re: Mylyn
Date Thu, 09 Jan 2014 18:47:12 GMT
On Thu, Jan 9, 2014 at 9:47 AM, Raffael Bachmann <bloodhound@qwas.li> wrote:

> Wow that was fast.
>
> And the error is gone (after removin dev mode from the egg version,
> since mylyn doesn't seem to like non numeric characters in the version).
>
>
ok , good to know it's finally solved
:)


> Unfortunately it is still not working.
> In the query editor there are no selectable options (see attached
> image). My interpretation of the log entries is, that it can not serve
> this because no product is selected:
>
> 2014-01-09 15:16:18,276 Trac[web_ui] DEBUG: RPC(XML-RPC) call by
> 'raffael' ticket.getTicketFields
> 2014-01-09 15:16:18,281 Trac[xml_rpc] DEBUG: RPC(xml)
> 'ticket.getTicketFields' result: [{'type': 'text', 'name': 'summary',
> 'label': u'Summary'}, {'type': 'text', 'name': 'reporter', 'label':
> u'Reporter'}, {'type': 'text', 'name': 'owner', 'label': u'Owner'},
> {'type': 'textarea', 'name': 'description', 'label': u'Description'},
> {'name': 'status', 'optional': True, 'value': '', 'label': u'Status',
> 'type': 'radio', 'options': [u'accepted', u'assigned', u'closed',
> u'new', u'reopened']}, {'name': 'product', 'optional': False, 'value':
> '', 'label': u'Product', 'pk': 'prefix', 'type': 'select', 'options':
> [u'domink', u'@']}, {'format': 'list', 'type': 'text', 'name':
> 'keywords', 'label': u'Keywords'}, {'format': 'list', 'type': 'text',
> 'name': 'cc', 'label': u'Cc'}, {'type': 'time', 'name': 'time', 'label':
> u'Created'}, {'type': 'time', 'name': 'changetime', 'label': u'Modified'}]
>
>
It seems to me that you have configured the RPC URL corresponding to the
global environment e.g. http://host.com/path/to/bh/env/rpc . There are no
values defined for ticket fields in the global environment (immediately
after default installation process) , therefore they are ignored .

cmiiw

If there is a way to select the Product in the url of the Task
> repository it might work better. If not I think it that the trac mylyn
> connector does not work without modification.
>

Bloodhound products have independent URL namespaces i.e. by following
sub-paths starting from product base URL you'll find all features available
in regular environments . For instance, RPC access to resources hosted by
product with prefix P is possible (after default install) at a URL of the
form

http://host.com/path/to/bh/env/products/P/rpc

Could you please try it that way ? In any case , I do not think Mylyn will
support multiple products in a single setup, so you'll end up mapping your
instance to a single BH product equivalent (API) to a Trac environment

N.B. Notice that Bloodhound (as opposite to Trac)  supports custom web
bootstrap handlers [1]_ for custom URL mappings . For instance in
blood-hound.net products are mapped onto sub-domains and therefore RPC URLs
look like

http://P.blood-hound.net/rpc

You could do so if you prefer but beware of the fact that product URLs will
be different .


> Still I tried to create a query that should return all Tasks, which
> resulted in some kind of error in mylyn because the tickets where
> returned wrong:
>
> 2014-01-09 15:19:56,806 Trac[xml_rpc] DEBUG: RPC(xml) call by 'raffael',
> method 'system.multicall' with args: ([{'methodName': 'ticket.get',
> 'params': [4]}, {'methodName': 'ticket.get', 'params': [12]}],)
> 2014-01-09 15:19:56,812 Trac[web_ui] DEBUG: RPC(XML-RPC) call by
> 'raffael' system.multicall
> 2014-01-09 15:19:56,987 Trac[xml_rpc] DEBUG: RPC(xml) 'system.multicall'
> result: [ResourceNotFound(u'Ticket 4 does not exist.',),
> ResourceNotFound(u'Ticket 12 does not exist.',)]
>
>
If using BH=0.7 then this might be caused by default product redirections
removed in /trunk (0.8-dev) . I tested against 0.8-dev


>
> Thanks again for you help
>

u'r welcome !
don't hesitate to continue asking more questions , it'd be nice to work
towards full compatibility with Mylyn connector ... preferably tested ...

.. [1] https://issues.apache.org/bloodhound/wiki/Proposals/BEP-0003#hooks

[...]

-- 
Regards,

Olemis - @olemislc

Apacheā„¢ Bloodhound contributor
http://issues.apache.org/bloodhound
http://blood-hound.net

Blog ES: http://simelo-es.blogspot.com/
Blog EN: http://simelo-en.blogspot.com/

Featured article:

Mime
View raw message