bloodhound-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bobby Ninan <bmni...@gmail.com>
Subject Re: Turning on source code browser
Date Tue, 12 Nov 2013 20:36:49 GMT
Your suggestion on navigating to /browser/<reponame> was very helpful. I
found that the problem was due to my incorrectly specifying the repository
directory. When I specified the directory as "/opt/git/foo.git", I was able
to navigate the source browser successfully.

Thanks,
Bobby...


On Tue, Nov 12, 2013 at 12:20 PM, Olemis Lang <olemis@gmail.com> wrote:

>
>
> On Tue, Nov 12, 2013 at 12:58 PM, Bobby Ninan <bmninan@gmail.com> wrote:
>
>> Hi,
>>
>
> :)
>
>
>> I have been trying unsuccessfully so far to view my Git repository in
>> Apache Bloodhound's source browser. I am using Bloodhound
>> 0.8.0dev-r1534486. Under the Administration (Global Settings) >
>> Repositories, I have added a Git repository "foo" in the directory
>> "/opt/git".
>>
>> When I login as admin, I do see the Source link. However clicking on it
>> takes me to the RepositoryAdmin wiki page.
>>
>
> yes, because you are in admin area, therefore by clicking on that anchor
> you'll navigate to repository admin panel
>
>
>> When I login as a non-admin user, I do not even see the Source link.
>>
>
> ... as expected ...
>
>
>> Can you please tell me what I may be missing here?
>>
>
> What do you see when you navigate to /browser/<reponame> ?
>
> Maybe we are lacking on offering a link for users to go straight to
> repository browser from corresponding admin pages . If you feel this is the
> case please create a new ticket .
>
> --
> Regards,
>
> Olemis - @olemislc
>
>

Mime
View raw message