bloodhound-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matevž Bradač <mat...@digiverse.si>
Subject Re: Bloodhound Login Error
Date Tue, 30 Jul 2013 09:03:48 GMT
On 30. Jul, 2013, at 10:45, Pedro Estrela wrote:

> I'm running as root.
> 
> Here is the result of pip freeze:
> 
> "
> Warning: cannot find svn location for BloodhoundMultiProduct==0.7.0dev-r1506070
> Warning: cannot find svn location for BloodhoundRelationsPlugin==0.7.0dev-r1503571
> Warning: cannot find svn location for BloodhoundTheme==0.7.0dev-r1506038
> Warning: cannot find svn location for BloodhoundSearchPlugin==0.7.0dev-r1503560
> Warning: cannot find svn location for BloodhoundDashboardPlugin==0.7.0dev-r1505871
> Warning: cannot find svn location for PEAK-Rules==0.5a1.dev-r2582
> AddOns==0.6
> Babel==0.9.4
> Beaker==1.3.1
> ## FIXME: could not find svn URL in dependency_links for this package:
> BloodhoundDashboardPlugin==0.7.0dev-r1505871
> ## FIXME: could not find svn URL in dependency_links for this package:
> BloodhoundMultiProduct==0.7.0dev-r1506070
> ## FIXME: could not find svn URL in dependency_links for this package:
> BloodhoundRelationsPlugin==0.7.0dev-r1503571
> ## FIXME: could not find svn URL in dependency_links for this package:
> BloodhoundSearchPlugin==0.7.0dev-r1503560
> ## FIXME: could not find svn URL in dependency_links for this package:
> BloodhoundTheme==0.7.0dev-r1506038
> BytecodeAssembler==0.5.1
> Cheetah==2.4.1
> DecoratorTools==1.7
> Extremes==1.1
> FormEncode==1.2.2
> Genshi==0.6
> Magic-file-extensions==0.1
> Mako==0.3.4
> Markdown==2.0.1
> MarkupSafe==0.9.2
> MySQL-python==1.2.3c1
> Myghty==1.1
> ## FIXME: could not find svn URL in dependency_links for this package:
> PEAK-Rules==0.5a1.dev-r2582
> Paste==1.7.4
> PasteDeploy==1.3.3
> PasteScript==1.7.3
> PyGreSQL==3.8.1
> Pygments==1.1.1
> Pylons==0.9.7
> Routes==1.10.3
> SQLAlchemy==0.5.5
> SSSDConfig==1.9.2
> SetupDocs==1.0.5
> SymbolType==1.0
> Tempita==0.4
> ToscaWidgets==0.9.8
> Trac==1.0.1
> TracAccountManager==0.4.3
> TracPermRedirect==3.0
> TracThemeEngine==2.2.0
> TurboGears2==2.0.3
> TurboJson==1.2.1
> WebError==0.10.2
> WebFlash==0.1a9
> WebHelpers==0.6.4
> WebOb==0.9.6.1
> WebTest==1.2
> Whoosh==2.4.1
> cas==0.15
> cups==1.0
> cupshelpers==1.0
> decorator==3.0.1
> distribute==0.6.10
> ethtool==0.6
> firstboot==1.110
> freeipa==2.0.0.alpha.0
> iniparse==0.3.1
> iotop==0.3.2
> ipapython==3.0.0
> iwlib==1.0
> kerberos==1.0
> luci==0.26.0
> lxml==2.2.3
> matplotlib==0.99.1.1
> netaddr==0.7.5
> nose==0.10.4
> numpy==1.4.1
> paramiko==1.7.5
> pexpect==2.3
> policycoreutils-default-encoding==0.1
> prioritized-methods==0.2.1
> psycopg2==2.0.14
> pyOpenSSL==0.10
> pyasn1==0.0.12a
> pycrypto==2.0.1
> pycurl==7.19.0
> pygpgme==0.1
> python-dateutil==1.4.1
> python-default-encoding==0.1
> python-ldap==2.3.10
> python-meh==0.11
> python-memcached==1.43
> python-nss==0.13
> pytz==2010h
> pyxdg==0.18
> qpid-python==0.14
> qpid-tools==0.14
> repoze.tm2==1.0a4
> repoze.what==1.0.8
> repoze.what-pylons==1.0
> repoze.who==1.0.18
> repoze.who-friendlyform==1.0.8
> repoze.who-testutil==1.0rc1
> scdate==1.9.60
> sckdump==2.0.5
> scservices==0.99.45
> scservices.dbus==0.99.45
> setools==1.0
> simplejson==2.0.9
> slip==0.2.20
> slip.dbus==0.2.20
> slip.gtk==0.2.20
> smbc==1.0
> sqlparse==0.1.7
> suds==0.4.1
> transaction==1.0.1
> urlgrabber==3.9.1
> virtualenv==1.9.1
> yum-metadata-parser==1.1.2
> zope.interface==3.5.2
> zope.sqlalchemy==0.4
> "
> 

Hmm, it does seem to be installed.
Are you also running Olemis' tests as root?

Could you also check that the top level BH/Trac modules can be imported
properly by the python interpreter, e.g.:
{{{#!py
  import genshi
  import babel
  import themeengine
  import acct_mgr
  import bhtheme
  import bhdashboard
  import bhsearch
  import multiproduct
  import bhrelations
}}}

> 
> 2013/7/30 Matevž Bradač <matevz@digiverse.si>
> 
> On 30. Jul, 2013, at 10:20, Pedro Estrela wrote:
> 
> > ">>> import acct_mgr.web_ui
> > Traceback (most recent call last):
> >   File "<stdin>", line 1, in <module>
> > ImportError: No module named acct_mgr.web_ui"
> >
> > I guess is missing something
> 
> Most likely it's not installed. Could you please provide the output of
>   pip freeze
> command so that we can determine which modules have been installed in
> the environment?
> 
> Also, how are you running your web server - as admin/root, or as a
> separate user?
> 
> >
> >
> > 2013/7/30 Olemis Lang <olemis@gmail.com>
> > On 7/29/13, Pedro Estrela <p.estrela@campus.fct.unl.pt> wrote:
> > > Hi,
> > >
> >
> > :)
> >
> > [...]
> > > Can you please tell me what i did wrong? This is the error that i get:
> > >
> > > "Error: Not Found
> > > No handler matched request to /login"
> > >
> >
> > This is an indication of the fact that account manager plugin has not
> > been ( detected / loaded / enabled ). Could you please launch your
> > python interpreter, execute the following code and tell us what's the
> > result ? Is it even close to what you see below?
> >
> > {{{#!py
> >
> > >>> from trac.env import open_environment as oe
> > >>> env = oe('/path/to/bh/env')
> > >>> import acct_mgr.web_ui
> > >>> env[web_ui.LoginModule]
> > <acct_mgr.web_ui.LoginModule object at 0x38a9710>
> > }}}
> >
> > --
> > Regards,
> >
> > Olemis - @olemislc
> >
> > Apache™ Bloodhound contributor
> > http://issues.apache.org/bloodhound
> > http://blood-hound.net
> >
> > Blog ES: http://simelo-es.blogspot.com/
> > Blog EN: http://simelo-en.blogspot.com/
> >
> > Featured article:
> >
> 
> 


Mime
View raw message