bloodhound-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Martin <gary.mar...@wandisco.com>
Subject Re: Bloodhound Login Error
Date Wed, 31 Jul 2013 12:43:38 GMT
On 31/07/13 12:48, Matevž Bradač wrote:
> On 31. Jul, 2013, at 10:54, Pedro Estrela wrote:
>
>> I did that command:
>>
>> tracd -p 8000 /var/www/bloodhound/installer/bloodhound/environments/main
>>
>> and i get this errors on localhost:8000/main :
>>
>> " Warning: Unknown theme bloodhound configured. Please check your trac.ini. You may
need to enable the theme's plugin."
>>
>> and
>>
>> " Trac detected an internal error:
>>
>> DataError: invalid input syntax for integer: "trac.wiki.api.WikiSystem.pages"
>> LINE 1: SELECT generation FROM cache WHERE id=E'trac.wiki.api.WikiSy...
>>                   
>>                              ^"
>>
>  From the looks of it, it seems like you have a corrupt virtual environment
> or something in that direction. I would suggest recreating the environment
> from scratch, under the same user account that will be used for running
> Apache. Note that you may have to manually remove Babel and replace it with an
> older version (use Babel==0.9.6 with pip), as the newer versions may not work.
> After the new environment has been set up, running a standalone tracd should
> work properly.
>
> Once this is fixed we can continue debugging the Apache issues.

This seems sensible. It might also be worth removing the system 
installed versions of the packages though if we can work out which they are.

I may not have been exhaustive in this list and it may be that some of 
these are installed from the CentOS repositories so you may need to be 
careful in case other programs need some of these.. however unless you 
expect to have Trac itself installed alongside, the following will 
hopefully be safe enough (deactivate included in case you are starting 
from an activated virtualenv):

deactivate
pip uninstall Babel
pip uninstall BloodhoundDashboardPlugin
pip uninstall BloodhoundMultiProduct
pip uninstall BloodhoundRelationsPlugin
pip uninstall BloodhoundSearchPlugin
pip uninstall BloodhoundTheme
pip uninstall Genshi
pip uninstall Pygments
pip uninstall Trac
pip uninstall TracAccountManager
pip uninstall TracPermRedirect
pip uninstall TracThemeEngine
pip uninstall Whoosh
pip uninstall sqlparse

Cheers,
     Gary

Mime
View raw message