bloodhound-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Apache Bloodhound" <bloodhound-...@incubator.apache.org>
Subject Re: [Apache Bloodhound] #42: Disable quick ticket button when user doesn't have sufficient permission
Date Tue, 01 May 2012 11:09:44 GMT
#42: Disable quick ticket button when user doesn't have sufficient permission
--------------------------+-------------------------------------
  Reporter:  jdreimann    |      Owner:  olemis
      Type:  enhancement  |     Status:  accepted
  Priority:  major        |  Milestone:  RC1 for initial release
 Component:  dashboard    |    Version:
Resolution:               |   Keywords:
--------------------------+-------------------------------------

Comment (by jdreimann):

 Olemis, I think this is better than before, but I believe the message
 should be friendlier or at least explain what happened better.
 When you currently go to the New Ticket screen without the appropriate
 permissions you get a message saying:

 "TICKET_CREATE privileges are required to perform this operation. You
 don't have the required permissions."
 I believe that's the message we should use, if possible from the same
 origin.

 The alert should be of the alert-info type, because we're just relaying
 some information - no need to issue an alert-'''error'''.

 Personally I would also drop the 'forbidden' label completely.

-- 
Ticket URL: <https://issues.apache.org/bloodhound/ticket/42#comment:7>
Apache Bloodhound <https://issues.apache.org/bloodhound/>
The Apache Bloodhound (incubating) issue tracker

Mime
View raw message