bigtop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Evans Ye <evan...@apache.org>
Subject Re: kafka component
Date Tue, 26 Sep 2017 06:39:34 GMT
On Bigtop side, we're allowed to redistribute Kafka only if Kafka released
new version which adopt new version of RocksDB which is duel licensed.
Since the rocksdb feature is used for Kafka Streams.
Bigtop Kafka shipped in 1.1.0 or 1.0.0 are not effected.
If older version of Kafka is acceptable for you, you can give it a try :)

2017-09-26 4:19 GMT+08:00 Konstantin Boudnik <cos@apache.org>:

> It has been removed recently [1] due to "Facebook BSD+Patents" license
> dangers (it is a category-X now). Hope it helps.
>
> [1] https://is.gd/O9gKf7
> --
>   With regards,
> Konstantin (Cos) Boudnik
> 2CAC 8312 4870 D885 8616  6115 220F 6980 1F27 E622
>
> Disclaimer: Opinions expressed in this email are those of the author,
> and do not necessarily represent the views of any company the author
> might be affiliated with at the moment of writing.
>
>
> On Mon, Sep 25, 2017 at 3:52 PM, Orjan Lundberg
> <orjan.lundberg@gmail.com> wrote:
> > Hi,
> >
> >
> > I tried to get the sandbox to install kafka but I could not get it to
> work.
> > I added the component "kafka" but got the following errors. (on master
> > branch and 1.2 branch)
> >
> > Is there such a component?
> >
> > Kind regards,
> > Örjan Lunberg
> >
> > ==> bigtop1: Error: Could not update: Execution of '/bin/yum -d 0 -e 0 -y
> > install kafka' returned 1: Delta RPMs disabled because
> > /usr/bin/applydeltarpm not installed.
> > ==> bigtop1:
> > ==> bigtop1:
> > ==> bigtop1: Error downloading packages:
> > ==> bigtop1:   kafka-0.10.1.1-1.el7.centos.noarch: [Errno 256] No more
> > mirrors to try.
> > ==> bigtop1: Error: /Stage[main]/Kafka::Server/Package[kafka]/ensure:
> change
> > from absent to latest failed: Could not update: Execution of '/bin/yum
> -d 0
> > -e 0 -y install kafka' returned 1: Delta RPMs disabled because
> > /usr/bin/applydeltarpm not installed.
> > ==> bigtop1:
> > ==> bigtop1:
> > ==> bigtop1: Error downloading packages:
> > ==> bigtop1:   kafka-0.10.1.1-1.el7.centos.noarch: [Errno 256] No more
> > mirrors to try.
> > ==> bigtop1: Warning:
> > /Stage[main]/Kafka::Server/File[/etc/kafka/conf/server.properties]:
> Skipping
> > because of failed dependencies
> > ==> bigtop1: Warning: /Stage[main]/Kafka::Server/Service[kafka-server]:
> > Skipping because of failed dependencies
> >
>

Mime
View raw message