bigtop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Konstantin Boudnik <...@apache.org>
Subject Re: Installation errors
Date Sat, 21 Nov 2015 19:18:36 GMT
David,

if you're trying to install the cluster from release 1.0.0 then YCSB isn't a
part of it. Release work started before the components has been added. 
You can try to use nightly builds from the master to add YCSB package to your
cluster
    http://ci.bigtop.apache.org/view/Bigtop-trunk/job/Bigtop-trunk-packages/ 

As for docker - it works pretty well, it seems, so you might want to give it a
try.

Hope it helps,
  Cos

On Sat, Nov 21, 2015 at 08:07PM, David Starina wrote:
> Hi,
> 
> I have tried to create a VM-based Hadoop cluster (is the Docker
> installation complete/stable? On the Bigtop website it said it is a work in
> progress, so I decided to go with the VM-based installation for now),
> following this guide:
> https://cwiki.apache.org/confluence/display/BIGTOP/Bigtop+Provisioner+User+Guide
> 
> Made the following changes to vagrantconfig.yaml, left everything else at
> default (CentOS 7 installation):
> 
> *memory_size: 3072*
> *num_instances: 2*
> *components: [hadoop, yarn, mahout, spark, ycsb]*
> Vagrant seemed to get a lot of the things right, but it did end with an
> error. Can you help me with that? I copied the errors (and one warning)
> that I got:
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> *==> bigtop1: sed: can't read /etc/sysconfig/rngd: No such file or
> directory==> bigtop1: Redirecting to /bin/systemctl start  rngd.service==>
> bigtop1: Redirecting to /bin/systemctl stop  iptables.service==> bigtop1:
> Failed to issue method call: Unit iptables.service not loaded.==> bigtop1:
> error reading information on service iptables: No such file or directory==>
> bigtop1: Warning: The use of 'import' is deprecated at
> /tmp/vagrant-puppet/manifests-f76206f1841b10444f0cea13160540f3/site.pp:71.
> See http://links.puppetlabs.com/puppet-import-deprecation
> <http://links.puppetlabs.com/puppet-import-deprecation>==> bigtop1:    (at
> /usr/share/ruby/vendor_ruby/puppet/parser/parser_support.rb:110:in
> `import')==> bigtop1: Error: Could not update: Execution of '/bin/yum -d 0
> -e 0 -y list ycsb' returned 1: Error: No matching Packages to list==>
> bigtop1: Error: /Stage[main]/Ycsb::Client/Package[ycsb]/ensure: change from
> absent to latest failed: Could not update: Execution of '/bin/yum -d 0 -e 0
> -y list ycsb' returned 1: Error: No matching Packages to listThe SSH
> command responded with a non-zero exit status. Vagrantassumes that this
> means the command failed. The output for this commandshould be in the log
> above. Please read the output to determine whatwent wrong.*
> 
> It seems the biggest error is the YCBS is not available (should any of the
> other errors worry me?). What did I do wrong - is YCBS no longer available
> in Bigtop? It is on the list of effective values that the guide links to.
> 
> Best regards,
> David

Mime
View raw message