bigtop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Roman Shaposhnik <ro...@shaposhnik.org>
Subject Re: Debian
Date Mon, 15 Sep 2014 01:57:26 GMT
Hi Olaf!

I'm sorry for the belated reply -- tons of travel :-(

Personally, I am super excited to see somebody trying
Bigtop out on pure Debian. In fact, if you could consider
becoming an official Debian maintainer for Bigtop -- that
would be tremendously appreciated.

The work would start with helping us bootstrap Debian
on our CI, but then just being able to provide feedback
would be huge.

Also, we could always use some more  Debian-centric
packaging expertise.

On Mon, Sep 8, 2014 at 1:54 AM, Olaf Flebbe
<o.flebbe@science-computing.de> wrote:
> Hi,
>
> since I am _compiling_ bigtop on debian (wheezy and currently jessie) I have a couple
> of issues. Some of them have tickets, others should be documented otherwise.
>
> * Be sure to have a en_US.UTF-8 locale. Pig compile script requires it. It may be
>   better to use C.UTF8 , since this is available everywhere.
>   generate it by hand with "dpkg-reconfigure locales"

Is there any reason we shouldn't be enforcing it 100%?

> * I had the problem that one of the compile jobs actually writes into FORREST_HOME (!)

Wow! Do you happen to remember what it was?

> * Debian Wheezy:
>    Following packages are too old int the Debian wheezy/stable repo to be used to compile:
>    scala-2.10.4 , ant-1.9.2, gradle-1.12, protobuf-c-compiler-2.5.0
>
>    You have to compile/install it yourself
>
>    I had very obscure maven problems. Had to switch several times until it finally worked.
>    The Download from maven.apache.org Version 3.0.5 finally worked best.

Yes. And that's why we have Puppet scripts setting up build environment
for the Bigtop builds. We're also in a process of producing pre-built
Docker containers with the build env. setup just right:
   https://hub.docker.com/u/bigtop/

Contributing Debian there would be the first step.

> * Wheezy:
>    hue: after initial "apt-get install hue" you get an django exception in the console
if used the first time:
>
>   File "/usr/lib/hue/build/env/lib/python2.7/site-packages/Mako-0.8.1-py2.7.egg/mako/template.py",
line 379, in _compile_from_file
>     module = compat.load_module(self.module_id, path)
>   File "/usr/lib/hue/build/env/lib/python2.7/site-packages/Mako-0.8.1-py2.7.egg/mako/compat.py",
line 55, in load_module
>     return imp.load_source(module_id, path, fp)
>   File "/tmp/tmpQHADWH/desktop/common_header.mako.py", line 26, in <module>
>     from search.search_controller import SearchController
> ImportError: No module named search.search_controller
>
>    service hue restart and hue seems to work

What was the rest of your experience working with freshly minted Hue?

> * Debian Jessy/testing:
>
>   I currently having very very very  very obscure maven problems.  Most of the time it
stopped in site:deploy Target of giraph. Error message : class StringUtils is missing in org.apache.commons.lang.
(All packages I found on this machine have it )
>   I am currently working on isolating the problem.

Any progress there?

> * It would be very helpful, if the jenkins setup whould be available.
>
> https://builds.apache.org/view/All/job/Bigtop-trunk/
>
> What does it do ? IMHO It does _not_ use gradle to compile ?

Currently it uses make, but we're very quickly migrating to gradle,
since make is going to be removed in Bigtop 0.9.0

Thanks,
Roman.

Mime
View raw message