bigtop-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jay vyas <jayunit100.apa...@gmail.com>
Subject Re: puppet error (probably my fault)
Date Fri, 04 Jul 2014 14:14:46 GMT
I made some progress on this ....By adding

notice("in common-hdfs $hadoop_namenode_host <<<< ")
file {
   "/etc/hadoop/conf/core-site.xml"
   content => template('hadoop/core-site.xml'),
   require => [Package["hadoop"]],
}

I see that I get no value:

Notice: Scope(Class[Hadoop::Common-hdfs]): in common-hdfs  <<<<<
Could not find value for 'hadoop_namenode_host'

So that is what breaks the parser : I guess it wants that value
("hadoop_namenode_host") to be defined, in order to properly parse the
template.

But it IS defined in the datanode snippet, just not in the common-hdfs
puppet snippet.

So some how that variable "loses" its scoping or definition in init.pp but
im not sure how.   I am suspecting maybe the version of puppet is important
here, or else, maybe the ordering of components, or some other system
specific aspect of my config (I DONT think this could be a bug, given that
so many people are succesfully using bigtop puppet recipes).





On Thu, Jul 3, 2014 at 11:40 PM, jay vyas <jayunit100.apache@gmail.com>
wrote:

> Hi bigtop !
>
> I've been playing with the puppet recipes, and am getting this error:
>
> Could not find value for 'hadoop_namenode_host' at
> /root/bigtop/bigtop-deploy/puppet/modules/hadoop/template/core-site.xml:19
>
> Any idea where that would come from ?
>
> I'm deploying from instructions in the README for bigtop-deploy/puppet ,
> with the following command:
>
>  puppet apply -d --confdir=/root/bigtop/bigtop-deploy/puppet/
> --modulepath=bigtop-deploy/puppet/modules
> bigtop-deploy/puppet/manifests/site.pp
>
> It appears to read the CSV file just fine, but seems to be choking on the
> "hadoop_namenode_host" variable --- probably this is a puppet variable
> scoping issue that I don't understand very well, or possibly a bug (but I
> doubt it since puppet recipes work just fine in vagrant).
>
> Also, maybe it could be a puppet versioning thing?  Im using puppet 3.6.2
>
> --
> jay vyas
>



-- 
jay vyas

Mime
View raw message