bigtop-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From evan...@apache.org
Subject [bigtop] 01/01: Revert "BIGTOP-3188. Bump Zeppelin to 0.8.1"
Date Fri, 15 Mar 2019 06:58:13 GMT
This is an automated email from the ASF dual-hosted git repository.

evansye pushed a commit to branch revert-496-BIGTOP-3188
in repository https://gitbox.apache.org/repos/asf/bigtop.git

commit 493d2c2f54f28fcfe3c893d5af8e4f23a018c9ce
Author: Evans Ye <evansye@apache.org>
AuthorDate: Fri Mar 15 14:58:07 2019 +0800

    Revert "BIGTOP-3188. Bump Zeppelin to 0.8.1"
---
 .../src/common/zeppelin/do-component-build         |  2 +
 .../zeppelin/patch0-resolve-version-conflicts.diff | 69 ----------------------
 .../zeppelin/patch1-sparkr-api-compatibility.diff  | 32 ----------
 .../src/rpm/zeppelin/SPECS/zeppelin.spec           |  3 -
 bigtop.bom                                         |  2 +-
 5 files changed, 3 insertions(+), 105 deletions(-)

diff --git a/bigtop-packages/src/common/zeppelin/do-component-build b/bigtop-packages/src/common/zeppelin/do-component-build
index 37e516c..311deeb 100644
--- a/bigtop-packages/src/common/zeppelin/do-component-build
+++ b/bigtop-packages/src/common/zeppelin/do-component-build
@@ -45,6 +45,8 @@ fi
 
 export MAVEN_OPTS="-Xmx1500m -Xms1500m"
 
+# change spark src download url to apache
+sed -i "s/http\:\/\/d3kbcqa49mib13\.cloudfront\.net/https\:\/\/archive\.apache\.org\/dist\/spark\/spark-\$\{spark\.version\}/g"
spark-dependencies/pom.xml
 mvn $BUILD_OPTS clean package
 
 mkdir -p build/dist
diff --git a/bigtop-packages/src/common/zeppelin/patch0-resolve-version-conflicts.diff b/bigtop-packages/src/common/zeppelin/patch0-resolve-version-conflicts.diff
deleted file mode 100644
index 8ced6eb..0000000
--- a/bigtop-packages/src/common/zeppelin/patch0-resolve-version-conflicts.diff
+++ /dev/null
@@ -1,69 +0,0 @@
-diff --git a/pom.xml b/pom.xml
-index 61646d655..f98b42cc4 100644
---- a/pom.xml
-+++ b/pom.xml
-@@ -264,6 +264,38 @@
-         <version>${shiro.version}</version>
-       </dependency>
-
-+      <!-- Resolve dependency conflicts -->
-+      <dependency>
-+              <groupId>org.codehaus.jackson</groupId>
-+              <artifactId>jackson-mapper-asl</artifactId>
-+              <version>1.9.13</version>
-+      </dependency>
-+      <dependency>
-+              <groupId>org.codehaus.jackson</groupId>
-+              <artifactId>jackson-core-asl</artifactId>
-+              <version>1.9.13</version>
-+      </dependency>
-+      <dependency>
-+              <groupId>org.apache.zookeeper</groupId>
-+              <artifactId>zookeeper</artifactId>
-+              <version>3.4.6</version>
-+      </dependency>
-+      <dependency>
-+              <groupId>com.amazonaws</groupId>
-+              <artifactId>aws-java-sdk-s3</artifactId>
-+              <version>1.10.62</version>
-+      </dependency>
-+      <dependency>
-+              <groupId>com.amazonaws</groupId>
-+              <artifactId>aws-java-sdk-core</artifactId>
-+              <version>1.10.62</version>
-+      </dependency>
-+      <dependency>
-+          <groupId>com.nimbusds</groupId>
-+          <artifactId>nimbus-jose-jwt</artifactId>
-+          <version>4.41.2</version>
-+      </dependency>
-+
-       <!-- Test libraries -->
-       <dependency>
-         <groupId>junit</groupId>
-diff --git a/spark/pom.xml b/spark/pom.xml
-index f461fea56..dfe328f46 100644
---- a/spark/pom.xml
-+++ b/spark/pom.xml
-@@ -45,8 +45,8 @@
-         <plugin.shade.version>2.4.1</plugin.shade.version>
-         <plugin.scala.version>2.15.2</plugin.scala.version>
-         <!-- spark versions -->
--        <spark.version>2.2.0</spark.version>
--        <py4j.version>0.10.4</py4j.version>
-+        <spark.version>2.2.3</spark.version>
-+        <py4j.version>0.10.7</py4j.version>
-
-         <spark.archive>spark-${spark.version}</spark.archive>
-         <spark.src.download.url>
-@@ -213,8 +213,8 @@
-         <profile>
-             <id>spark-2.2</id>
-             <properties>
--                <spark.version>2.2.1</spark.version>
--                <py4j.version>0.10.4</py4j.version>
-+                <spark.version>2.2.3</spark.version>
-+                <py4j.version>0.10.7</py4j.version>
-             </properties>
-             <activation>
-                 <activeByDefault>true</activeByDefault>
diff --git a/bigtop-packages/src/common/zeppelin/patch1-sparkr-api-compatibility.diff b/bigtop-packages/src/common/zeppelin/patch1-sparkr-api-compatibility.diff
deleted file mode 100644
index 94f0960..0000000
--- a/bigtop-packages/src/common/zeppelin/patch1-sparkr-api-compatibility.diff
+++ /dev/null
@@ -1,32 +0,0 @@
-diff --git a/spark/scala-2.10/src/main/scala/org/apache/zeppelin/spark/SparkScala210Interpreter.scala
b/spark/scala-2.10/src/main/scala/org/apache/zeppelin/spark/SparkScala210Interpreter.scala
-index 995ee1539..9d2ac83e0 100644
---- a/spark/scala-2.10/src/main/scala/org/apache/zeppelin/spark/SparkScala210Interpreter.scala
-+++ b/spark/scala-2.10/src/main/scala/org/apache/zeppelin/spark/SparkScala210Interpreter.scala
-@@ -67,7 +67,6 @@ class SparkScala210Interpreter(override val conf: SparkConf,
-     settings.embeddedDefaults(Thread.currentThread().getContextClassLoader())
-     settings.usejavacp.value = true
-     settings.classpath.value = getUserJars.mkString(File.pathSeparator)
--    sparkILoop = new SparkILoop(null, new JPrintWriter(Console.out, true))
-     if (printReplOutput) {
-       Console.setOut(interpreterOutput)
-     }
-diff --git a/r/src/main/scala/org/apache/spark/api/r/RBackendHelper.scala b/r/src/main/scala/org/apache/spark/api/r/RBackendHelper.scala
-index 9c1eb38d5..155f645dc 100644
---- a/r/src/main/scala/org/apache/spark/api/r/RBackendHelper.scala
-+++ b/r/src/main/scala/org/apache/spark/api/r/RBackendHelper.scala
-@@ -30,7 +30,7 @@ class RBackendHelper(val backend : RBackend) {
-   var port : Int = 0
-
-   def init() : Int = {
--    port = backend.init()
-+    port = backend.init()._1
-     port
-   }
-
-@@ -81,4 +81,4 @@ Its for testing purposes and should never be called
-
-   def apply() : RBackendHelper = new RBackendHelper(new RBackend())
-
--}
-\ No newline at end of file
-+}
diff --git a/bigtop-packages/src/rpm/zeppelin/SPECS/zeppelin.spec b/bigtop-packages/src/rpm/zeppelin/SPECS/zeppelin.spec
index 931b565..822503b 100644
--- a/bigtop-packages/src/rpm/zeppelin/SPECS/zeppelin.spec
+++ b/bigtop-packages/src/rpm/zeppelin/SPECS/zeppelin.spec
@@ -51,7 +51,6 @@ Source3: init.d.tmpl
 Source4: install_zeppelin.sh
 Source5: zeppelin-env.sh
 Source6: zeppelin.svc
-#BIGTOP_PATCH_FILES
 Requires: bigtop-utils >= 0.7, hadoop-client, spark-core >= 1.5, spark-python >=
1.5
 Requires(preun): /sbin/service
 AutoReq: no
@@ -78,8 +77,6 @@ You can make beautiful data-driven, interactive and collaborative documents
with
 %prep
 %setup -n %{name}-%{zeppelin_base_version}
 
-#BIGTOP_PATCH_COMMANDS
-
 %build
 bash $RPM_SOURCE_DIR/do-component-build
 
diff --git a/bigtop.bom b/bigtop.bom
index 9b44e2c..2835289 100644
--- a/bigtop.bom
+++ b/bigtop.bom
@@ -401,7 +401,7 @@ bigtop {
     'zeppelin' {
       name    = 'zeppelin'
       relNotes = 'Apache Zeppelin'
-      version { base = '0.8.1'; pkg = base; release = 1 }
+      version { base = '0.7.3'; pkg = base; release = 1 }
       tarball { source      = "$name-${version.base}.tgz"
                 destination = "$name-${version.base}.tar.gz" }
       url     { download_path = "/$name/$name-${version.base}/"


Mime
View raw message