bigtop-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ofle...@apache.org
Subject bigtop git commit: BIGTOP-2641: Remove JDK7 // only support JDK8
Date Fri, 23 Dec 2016 10:15:35 GMT
Repository: bigtop
Updated Branches:
  refs/heads/master b42e016c1 -> c37c86bcf


BIGTOP-2641: Remove JDK7 // only support JDK8


Project: http://git-wip-us.apache.org/repos/asf/bigtop/repo
Commit: http://git-wip-us.apache.org/repos/asf/bigtop/commit/c37c86bc
Tree: http://git-wip-us.apache.org/repos/asf/bigtop/tree/c37c86bc
Diff: http://git-wip-us.apache.org/repos/asf/bigtop/diff/c37c86bc

Branch: refs/heads/master
Commit: c37c86bcfacd353d9766811d2ad5ced86f9b2ff8
Parents: b42e016
Author: Olaf Flebbe <of@oflebbe.de>
Authored: Thu Dec 22 16:17:31 2016 +0100
Committer: Olaf Flebbe <of@oflebbe.de>
Committed: Fri Dec 23 11:00:20 2016 +0100

----------------------------------------------------------------------
 bigtop_toolchain/manifests/jdk.pp | 42 +---------------------------------
 1 file changed, 1 insertion(+), 41 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/bigtop/blob/c37c86bc/bigtop_toolchain/manifests/jdk.pp
----------------------------------------------------------------------
diff --git a/bigtop_toolchain/manifests/jdk.pp b/bigtop_toolchain/manifests/jdk.pp
index afbef23..b15539d 100644
--- a/bigtop_toolchain/manifests/jdk.pp
+++ b/bigtop_toolchain/manifests/jdk.pp
@@ -19,29 +19,13 @@ class bigtop_toolchain::jdk {
       require apt
       require apt::backports
 
-      package { 'openjdk-7-jdk' :
-        ensure => present,
-      }
-
       package { 'openjdk-8-jdk' :
         ensure => present,
       }
-
-      exec { '/usr/sbin/update-alternatives --set javac /usr/lib/jvm/java-8-openjdk-amd64/bin/javac':
-        require => Package['openjdk-7-jdk', 'openjdk-8-jdk']
-      }
-      exec { '/usr/sbin/update-alternatives --set java /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java':
-        require => Package['openjdk-7-jdk', 'openjdk-8-jdk']
-      }
     }
     /Ubuntu/: {
       include apt
 
-      package { 'openjdk-7-jdk' :
-        ensure  => present,
-        # needed for 16.04
-        require => [ Apt::Ppa[ 'http://ppa.launchpad.net/openjdk-r/ppa/ubuntu'], Class['apt::update']
]
-      }
       package { 'openjdk-8-jdk' :
         ensure  => present,
         # needed for 14.04 
@@ -53,37 +37,13 @@ class bigtop_toolchain::jdk {
         server => 'keyserver.ubuntu.com'
       }  ->
       apt::ppa { 'http://ppa.launchpad.net/openjdk-r/ppa/ubuntu':  }
-
-      exec { '/usr/bin/update-alternatives --set javac /usr/lib/jvm/java-8-openjdk-amd64/bin/javac':
-        require => Package['openjdk-7-jdk', 'openjdk-8-jdk']
-      }
-      exec { '/usr/bin/update-alternatives --set java /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java':
-        require => Package['openjdk-7-jdk', 'openjdk-8-jdk']
-      }
-    }
-    /(CentOS|Amazon)/: {
-      package { 'java-1.7.0-openjdk-devel' :
-        ensure => present
-      }
-      package { 'java-1.8.0-openjdk-devel' :
-        ensure => present
-      }
-      # java 1.8 
     }
-    /Fedora/: {
-      if 0 + $::operatingsystemrelease < 21 {
-        package { 'java-1.7.0-openjdk-devel' :
-          ensure => present
-        }
-      }
+    /(CentOS|Amazon|Fedora)/: {
       package { 'java-1.8.0-openjdk-devel' :
         ensure => present
       }
     }
     /OpenSuSE/: {
-      package { 'java-1_7_0-openjdk-devel' :
-        ensure => present
-      }
       package { 'java-1_8_0-openjdk-devel' :
         ensure => present
       }


Mime
View raw message