bigtop-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From c..@apache.org
Subject bigtop git commit: BIGTOP-2323. Build slaves toolchain needs to be updated for HAWQ
Date Thu, 17 Mar 2016 18:51:29 GMT
Repository: bigtop
Updated Branches:
  refs/heads/BIGTOP-2320 3cee57abc -> 9cd5be13d


BIGTOP-2323. Build slaves toolchain needs to be updated for HAWQ

epel-release has to be install before any other packages. Otherwise toolchain fails on thrift
and shit


Project: http://git-wip-us.apache.org/repos/asf/bigtop/repo
Commit: http://git-wip-us.apache.org/repos/asf/bigtop/commit/9cd5be13
Tree: http://git-wip-us.apache.org/repos/asf/bigtop/tree/9cd5be13
Diff: http://git-wip-us.apache.org/repos/asf/bigtop/diff/9cd5be13

Branch: refs/heads/BIGTOP-2320
Commit: 9cd5be13da2db11e5e4110916fe0520ee2848ed7
Parents: 3cee57a
Author: Cos <cos@apache.org>
Authored: Thu Mar 17 13:50:26 2016 -0500
Committer: Cos <cos@apache.org>
Committed: Thu Mar 17 13:50:26 2016 -0500

----------------------------------------------------------------------
 bigtop_toolchain/manifests/packages.pp | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/bigtop/blob/9cd5be13/bigtop_toolchain/manifests/packages.pp
----------------------------------------------------------------------
diff --git a/bigtop_toolchain/manifests/packages.pp b/bigtop_toolchain/manifests/packages.pp
index 1c63e1b..baaa5e9 100644
--- a/bigtop_toolchain/manifests/packages.pp
+++ b/bigtop_toolchain/manifests/packages.pp
@@ -22,7 +22,9 @@ class bigtop_toolchain::packages {
        } else {
          $mysql_devel="mariadb-devel"
        }
-       $pkgs = [ "unzip", "curl", "libcurl-devel", "wget", "git", "make", "cmake", "autoconf",
"automake", "libtool", "apr-devel", "bison", "gcc", "gcc-c++", "fuse", "createrepo", "lzo-devel",
"bzip2-devel", "fuse-devel", "cppunit-devel", "gperf", "openssl-devel", "python-devel", "python-setuptools",
"libxml2-devel", "libxslt-devel", "libuuid-devel", "libgsasl-devel", "libevent-devel", "json-c-devel",
"cyrus-sasl-devel", "sqlite-devel", "openldap-devel", $mysql_devel, "rpm-build", "redhat-rpm-config",
"fuse-libs", "asciidoc", "xmlto", "libyaml-devel", "gmp-devel", "readline-devel", "snappy-devel",
"epel-release", "thrift-devel" ]
+       $pkgs = [ "unzip", "curl", "libcurl-devel", "wget", "git", "make", "cmake", "autoconf",
"automake", "libtool", "apr-devel", "bison", "gcc", "gcc-c++", "fuse", "createrepo", "lzo-devel",
"bzip2-devel", "fuse-devel", "cppunit-devel", "gperf", "openssl-devel", "python-devel", "python-setuptools",
"libxml2-devel", "libxslt-devel", "libuuid-devel", "libgsasl-devel", "libevent-devel", "json-c-devel",
"cyrus-sasl-devel", "sqlite-devel", "openldap-devel", $mysql_devel, "rpm-build", "redhat-rpm-config",
"fuse-libs", "asciidoc", "xmlto", "libyaml-devel", "gmp-devel", "readline-devel", "snappy-devel",
"thrift-devel" ]
+       exec { '/usr/bin/yum install -y epel-release':
+       } -> Package <| |>
      }
     /(?i:(SLES|opensuse))/: { $pkgs = [ "unzip", "curl", "libcurl-devel", "wget", "git",
"make", "cmake", "autoconf", "automake", "libtool", "apr-devel", "bison", "gcc", "gcc-c++",
"fuse", "createrepo", "lzo-devel", "bzip2-devel", "fuse-devel", "cppunit-devel", "gperf",
"libopenssl-devel", "rpm-devel", "rpm-build", "pkg-config", "gmp-devel", "python-devel", "python-setuptools",
"libxml2-devel", "libxslt-devel", "libuuid-devel", "libgsasl-devel", "libevent-devel", "json-c-devel",
"cyrus-sasl-devel", "sqlite3-devel", "openldap2-devel", "libyaml-devel", "krb5-devel", "asciidoc",
"xmlto", "libmysqlclient-devel", "readline-devel", "snappy-devel" ]
       # fix package dependencies: BIGTOP-2120 and BIGTOP-2152


Mime
View raw message