bigtop-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From c..@apache.org
Subject bigtop git commit: BIGTOP-2323. libcurl-devel is needed for whatever reason.
Date Tue, 16 Feb 2016 11:47:51 GMT
Repository: bigtop
Updated Branches:
  refs/heads/BIGTOP-2320 5372c471e -> 568e0bce0


BIGTOP-2323. libcurl-devel is needed for whatever reason.


Project: http://git-wip-us.apache.org/repos/asf/bigtop/repo
Commit: http://git-wip-us.apache.org/repos/asf/bigtop/commit/568e0bce
Tree: http://git-wip-us.apache.org/repos/asf/bigtop/tree/568e0bce
Diff: http://git-wip-us.apache.org/repos/asf/bigtop/diff/568e0bce

Branch: refs/heads/BIGTOP-2320
Commit: 568e0bce09cceab7141d8b50091c5b5d67d20ecf
Parents: 5372c47
Author: Konstantin Boudnik <cos@apache.org>
Authored: Tue Feb 16 14:39:42 2016 +0300
Committer: Konstantin Boudnik <cos@apache.org>
Committed: Tue Feb 16 14:39:42 2016 +0300

----------------------------------------------------------------------
 bigtop_toolchain/manifests/packages.pp | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/bigtop/blob/568e0bce/bigtop_toolchain/manifests/packages.pp
----------------------------------------------------------------------
diff --git a/bigtop_toolchain/manifests/packages.pp b/bigtop_toolchain/manifests/packages.pp
index 0b7cc64..12a2918 100644
--- a/bigtop_toolchain/manifests/packages.pp
+++ b/bigtop_toolchain/manifests/packages.pp
@@ -22,16 +22,16 @@ class bigtop_toolchain::packages {
        } else {
          $mysql_devel="mariadb-devel"
        }
-       $pkgs = [ "unzip", "curl", "wget", "git", "make", "cmake", "autoconf", "automake",
"libtool", "apr-devel", "bison", "gcc", "gcc-c++", "fuse", "createrepo", "lzo-devel", "bzip2-devel",
"fuse-devel", "cppunit-devel", "gperf", "openssl-devel", "python-devel", "python-setuptools",
"libxml2-devel", "libxslt-devel", "libuuid-devel", "libgsasl-devel", "libevent-devel", "json-c-devel",
"cyrus-sasl-devel", "sqlite-devel", "openldap-devel", $mysql_devel, "rpm-build", "redhat-rpm-config",
"fuse-libs", "asciidoc", "xmlto", "libyaml-devel", "gmp-devel", "readline-devel", "snappy-devel"
]
+       $pkgs = [ "unzip", "curl", "libcurl-devel", "wget", "git", "make", "cmake", "autoconf",
"automake", "libtool", "apr-devel", "bison", "gcc", "gcc-c++", "fuse", "createrepo", "lzo-devel",
"bzip2-devel", "fuse-devel", "cppunit-devel", "gperf", "openssl-devel", "python-devel", "python-setuptools",
"libxml2-devel", "libxslt-devel", "libuuid-devel", "libgsasl-devel", "libevent-devel", "json-c-devel",
"cyrus-sasl-devel", "sqlite-devel", "openldap-devel", $mysql_devel, "rpm-build", "redhat-rpm-config",
"fuse-libs", "asciidoc", "xmlto", "libyaml-devel", "gmp-devel", "readline-devel", "snappy-devel"
]
      }
-    /(?i:(SLES|opensuse))/: { $pkgs = [ "unzip", "curl", "wget", "git", "make", "cmake",
"autoconf", "automake", "libtool", "apr-devel", "bison", "gcc", "gcc-c++", "fuse", "createrepo",
"lzo-devel", "bzip2-devel", "fuse-devel", "cppunit-devel", "gperf", "libopenssl-devel", "rpm-devel",
"rpm-build", "pkg-config", "gmp-devel", "python-devel", "python-setuptools", "libxml2-devel",
"libxslt-devel", "libuuid-devel", "libgsasl-devel", "libevent-devel", "json-c-devel", "cyrus-sasl-devel",
"sqlite3-devel", "openldap2-devel", "libyaml-devel", "krb5-devel", "asciidoc", "xmlto", "libmysqlclient-devel",
"readline-devel", "snappy-devel" ]
+    /(?i:(SLES|opensuse))/: { $pkgs = [ "unzip", "curl", "libcurl-devel", "wget", "git",
"make", "cmake", "autoconf", "automake", "libtool", "apr-devel", "bison", "gcc", "gcc-c++",
"fuse", "createrepo", "lzo-devel", "bzip2-devel", "fuse-devel", "cppunit-devel", "gperf",
"libopenssl-devel", "rpm-devel", "rpm-build", "pkg-config", "gmp-devel", "python-devel", "python-setuptools",
"libxml2-devel", "libxslt-devel", "libuuid-devel", "libgsasl-devel", "libevent-devel", "json-c-devel",
"cyrus-sasl-devel", "sqlite3-devel", "openldap2-devel", "libyaml-devel", "krb5-devel", "asciidoc",
"xmlto", "libmysqlclient-devel", "readline-devel", "snappy-devel" ]
       # fix package dependencies: BIGTOP-2120 and BIGTOP-2152
       exec { '/usr/bin/zypper remove -y krb5-mini':
       } -> exec {'/usr/bin/zypper install -y libopenssl-devel':
       } -> Package <| |>
     }
-    Amazon: {                 $pkgs = [ "unzip", "curl", "wget", "git", "make", "cmake",
"autoconf", "automake", "libtool", "apr-devel", "bison", "gcc", "gcc-c++", "fuse", "createrepo",
"lzo-devel", "bzip2-devel", "fuse-devel", "gperf", "libuuid-devel", "libgsasl-devel", "libevent-devel",
"json-c-devel", "openssl-devel", "rpm-build", "system-rpm-config", "fuse-libs","gmp-devel",
"readline-devel", "snappy-devel" ] }
-    /(Ubuntu|Debian)/: {      $pkgs = [ "unzip", "curl", "wget", "git-core", "make", "cmake",
"autoconf", "automake", "libtool", "apr-devel", "bison", "gcc", "g++", "fuse", "reprepro",
"liblzo2-dev", "bzip2-devel", "libfuse-dev", "libcppunit-dev", "libssl-dev", "libzip-dev",
"sharutils", "pkg-config", "debhelper", "devscripts", "build-essential", "dh-make", "libfuse2",
"libssh-dev", "libjansi-java", "python2.7-dev", "libxml2-dev", "libxslt1-dev", "zlib1g-dev",
"libsqlite3-dev", "libldap2-dev", "libsasl2-dev", "libmysqlclient-dev", "gperf", "libuuid-devel",
"libgsasl-devel", "libevent-devel", "json-c-devel", "python-setuptools", "libkrb5-dev", "asciidoc",
"libyaml-dev", "libgmp-dev", "readline-devel", "libsnappy-dev" ]
+    Amazon: {                 $pkgs = [ "unzip", "curl", "libcurl-devel", "wget", "git",
"make", "cmake", "autoconf", "automake", "libtool", "apr-devel", "bison", "gcc", "gcc-c++",
"fuse", "createrepo", "lzo-devel", "bzip2-devel", "fuse-devel", "gperf", "libuuid-devel",
"libgsasl-devel", "libevent-devel", "json-c-devel", "openssl-devel", "rpm-build", "system-rpm-config",
"fuse-libs","gmp-devel", "readline-devel", "snappy-devel" ] }
+    /(Ubuntu|Debian)/: {      $pkgs = [ "unzip", "curl", "libcurl-devel", "wget", "git-core",
"make", "cmake", "autoconf", "automake", "libtool", "apr-devel", "bison", "gcc", "g++", "fuse",
"reprepro", "liblzo2-dev", "bzip2-devel", "libfuse-dev", "libcppunit-dev", "libssl-dev", "libzip-dev",
"sharutils", "pkg-config", "debhelper", "devscripts", "build-essential", "dh-make", "libfuse2",
"libssh-dev", "libjansi-java", "python2.7-dev", "libxml2-dev", "libxslt1-dev", "zlib1g-dev",
"libsqlite3-dev", "libldap2-dev", "libsasl2-dev", "libmysqlclient-dev", "gperf", "libuuid-devel",
"libgsasl-devel", "libevent-devel", "json-c-devel", "python-setuptools", "libkrb5-dev", "asciidoc",
"libyaml-dev", "libgmp-dev", "readline-devel", "libsnappy-dev" ]
 
       exec { "apt-update":
         command => "/usr/bin/apt-get update"


Mime
View raw message