beehive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bryan Che <>
Subject Re: pageflow tutorial question
Date Thu, 14 Oct 2004 13:52:53 GMT
Hi, I found the problem.  In Step 3, your Controller.jpf source is 
missing the "@Jpf.Controller" annotation for the Controller class. 
After adding that annotation, I was able to navigate to page2 fine.


Steve Hanson wrote:
> Ok, that is a real problem.
> Are you stopping and restarting Tomcat between each step?  That may make a difference.
> Also, I just updated the tutorial as of 4 minutes ago.  So the changes should be public
by now.
> -Steve H.
> -----Original Message-----
> From: Bryan Che []
> Sent: Wednesday, October 13, 2004 2:52 PM
> To: Beehive Users
> Subject: Re: pageflow tutorial question
> Well, it's more than an annoyance in that the tutorial/beehive doesn't 
> work. =p  I haven't seen the app work at all yet beyond the index page.
> Bryan
> Steve Hanson wrote:
>>I don't know of any other trick to try.
>>One question: is this error anything more than an annoyance?  Or is it interfering
with the tutorial in some other way?
>>BTW: I will be updating the tutorial tonight, so it should work smoother in other
ways.  You are no longer directed to open and close all those command shells, etc.
>>-Steve Hanson
>>-----Original Message-----
>>From: Bryan Che []
>>Sent: Wednesday, October 13, 2004 2:17 PM
>>To: Steve Hanson
>>Subject: Re: pageflow tutorial question
>>Hi Steve, thanks for the quick response (I'm cc'ing to beehive-user in 
>>case this is useful to anyone else).  I tried completely deleting my 
>>WEB-INF directory, recreating it, and then rebuilding my webapp.  I 
>>still get the "Action Not Found" error.  Do you know if there's anything 
>>else I can try?
>>Steve Hanson wrote:
>>>Hi Bryan:
>>>Yeah, I get that too.  I only get it intermittently.  If you clean out all your
gen'd files in WEB-INF (like the classes, .pageflow-struts-generated, and .tmpbeansrc folders),
and compile again, you won't see the error.  But if you compile without cleaning out the gen'd
files, the error occurs ~80% of the time (at least for me).
>>>I don't think this is a problem with the tutorial is some problem with
the compiler.
>>>-Steve Hanson
>>>-----Original Message-----
>>>From: Bryan Che []
>>>Sent: Wednesday, October 13, 2004 1:56 PM
>>>To: Steve Hanson
>>>Subject: pageflow tutorial question
>>>Hi Steve, I've been trying out your pageflow tutorial on beehive.  But, 
>>>at step 3, the navigation step, I get the following error after starting 
>>>tomcat and clicking on the link to page2.:
>>>Page Flow Error - Action Not Found
>>>Page Flow:
>>>Action:	toPage2
>>>Form:	null
>>>Unable to find matching action toPage2.
>>>The toPage2 method is in my Controller.jpf file.  But, I did notice some 
>>>warnings when trying to build the webapp:
>>>/home/bche/src/svn/beehive/trunk/test/ant/>ant -f buildWebapp.xml 
>>>Buildfile: buildWebapp.xml
>>>   [delete] Deleting directory 
>>>[xmlbeanbuild] Could not find any xsd or wsdl files to process.
>>>     [echo] ========== Complie Java source in WEB-INF/src ==========
>>>     [echo] netui-compiler.jar: 
>>>     [echo] controls.jar: 
>>>     [echo] ========== Generate and compile controls ==========
>>>    [mkdir] Created dir: 
>>>     [echo] ========== Compile Page Flows ==========
>>>      [apt] Compiling 1 source file to 
>>>      [apt] 

>>>warning: File "/Controller.jpf" could not be found in the web application.
>>>      [apt]     public Forward home()
>>>      [apt]                    ^
>>>      [apt] 1 warning
>>>     [echo] Copy all .properties files
>>>     [echo] Copy all .xml files
>>>Total time: 3 seconds
>>>Controller.jpf is in my filesystem:

>>>Any idea what's wrong?

Bryan Che
Red Hat, Inc.
10 Technology Park
Westford, MA 01886

View raw message