beehive-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eddie O'Neil" <>
Subject Re: Build failure
Date Sat, 18 Sep 2004 17:06:59 GMT

  Huh...haven't seen this one before.  I just tried this with your JDK 
build / Ant install on WinXP and was successful with an "ant clean 
deploy" and "ant drt".

  The differences in our configs seems to be:

- the path length to BEEHIVE_HOME -- mine is c:\dev\apache\beehive\trunk
- you're running Win 2K and I'm on WinXP
- you're using your own version of Tomcat and not the one that we 
currently support in the builds -- 

  For the latter, we'd like to get to a point where devs / users can use 
various version of Tomcat; we've just not got enough (any?) mileage on 
this configuration yet.  Given that you're picking up a different 
CATALINA_HOME directory, is there any chance that you're also picking up 
a different ANT_HOME directory?

  Hope that helps.


Olaf Bergner wrote:

>since yesterday I am trying to build Beehive. My build environment:
>OS:			Windows 2000 SP4
>JDK:			java version "1.5.0-rc"
>			Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0-rc-b63)
>			Java HotSpot(TM) Client VM (build 1.5.0-rc-b63, mixed mode, sharing)
>Sources from:
>I did a fresh install of Jdk1.5.0RC, verified my installation via
>java -version the output of wich you see above, made a clean checkout of the
>beehive sources from the location mentioned in the wiki and followed the
>instructions in BUILDING.txt to the point:
>(1) Set JAVA_HOME to the root directory of Jdk1.5.0RC.
>(2) Set BEEHIVE_HOME to the root directory of my checked out sources.
>(3) unzipped external/ant/ into
>(4) Ran ant bootstrap (successful)
>(5) Ran ant clean deploy (failed)
>Building the tags-html module fails with xdoclet complaining about not being
>able to load the class implementing the subtask netuitldgen. To be more
>     [echo] compile module: tags-html
>     [echo] module.classpath:
>     [echo] debug: true
>    [mkdir] Created dir:
>    [javac] Compiling 114 source files to
>[buildmodules] Note: * uses or overrides a deprecated API.
>[buildmodules] Note: Recompile with -Xlint:deprecation for details.
>[buildmodules] Note: Some input files use unchecked or unsafe operations.
>[buildmodules] Note: Recompile with -Xlint:unchecked for details.
>     [copy] Copying 10 files to
>     [echo] Generate TLD and TLDx
>     [echo]
>1: The following error occurred while executing this line:
>.xml:16: The following error occurred while executing this line:
>uild.xml:34: The following error occurred while executing this line:
>uildModules.xml:24: The following error occurred while executing this line:
>ags-html\build.xml:38: Can't create a netuitldgen element under webdoclet.
>Make sure the jar file containing the corresponding subtask class is on the
>classpath specified in the <taskdef> that defined {2}.
>Total time: 1 minute 21 seconds
>A quick examination of the revealed
>bootstrap.jar to be a hot candidate for the presumably missing subtask since
>it has all the telltale signs of an xdoclet module. Still the build fails.
>Any hints?

View raw message