beehive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alejandro Ramirez (JIRA)" <...@beehive.apache.org>
Subject [jira] Closed: (BEEHIVE-828) @VersionRequired not supported on @ControlInterface
Date Fri, 28 Apr 2006 22:20:39 GMT
     [ http://issues.apache.org/jira/browse/BEEHIVE-828?page=all ]
     
Alejandro Ramirez closed BEEHIVE-828:
-------------------------------------

    Assign To:     (was: James Song)

(Visible to beehive-developers)


> @VersionRequired not supported on @ControlInterface
> ---------------------------------------------------
>
>          Key: BEEHIVE-828
>          URL: http://issues.apache.org/jira/browse/BEEHIVE-828
>      Project: Beehive
>         Type: Bug

>   Components: Controls
>     Versions: v1m1
>     Reporter: James Song

>
> This is a follow-up of JIRA230, and JIRA-118 is related to this.
> Currently, @VersionRequired on ControlInterface causes a compile error. But, according
to http://incubator.apache.org/beehive/controls/controlsProgramming.html#Defining+an+Extended+Interface+for+a+Control+Type
, an entended control interface could be declared with @ControlInterface.
> Not supporting @VersionRequired on ControlInterface mean version control is incomplete.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message