beehive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rich Feit (JIRA)" <...@beehive.apache.org>
Subject [jira] Created: (BEEHIVE-999) Deprecate 'validatorVersion' annotation and replace it with project-wide configuration
Date Wed, 09 Nov 2005 04:28:23 GMT
Deprecate 'validatorVersion' annotation and replace it with project-wide configuration
--------------------------------------------------------------------------------------

         Key: BEEHIVE-999
         URL: http://issues.apache.org/jira/browse/BEEHIVE-999
     Project: Beehive
        Type: Improvement
  Components: NetUI  
    Versions: V1    
    Reporter: Rich Feit
     Fix For: 1.1


There is a 'validatorVersion' attribute on the @Jpf.Controller annotation.  This attribute
controls which version of Commons Validator is being targeted.  Ideally, this would not be
in the annotation set at all -- it's way too implementation-specific.  It should be a project-wide
configuration.  The problem was (and is) that this may require parsing of beehive-netui-config.xml
on each pass of annotation processing in apt, unless there's a good way to cache this.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message