beehive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeremiah Johnson" <jerjo...@bea.com>
Subject RE: build problem with webservice-control
Date Wed, 01 Jun 2005 22:52:39 GMT
I don't think that it is fixed, yet.  I think you are missing a 'jars'
in build-svn.xml

One more time.

- jeremiah

> -----Original Message-----
> From: Eddie O'Neil
> Sent: Wednesday, June 01, 2005 4:35 PM
> To: Beehive Developers
> Subject: Re: build problem with webservice-control
> 
> 
>    Should be fixed in SVN 179439.
> 
>    :)
> 
> 
> 
> Eddie O'Neil wrote:
> >
> >   Probably also mine as well -- I'll give it a spin on a clean
machine.
> >
> > Eddie
> >
> >
> >
> > Patrick Osborne wrote:
> >
> >>
> >> I now have a failure during distribution, looks like soap stuff:
> >>
> >> gen-svc-ctrl:
> >>     [echo] cp:
> >> /perf/beehive/trunk/samples/controls-webservices-
> blank/build/classes:/perf/beehive/trunk/syste
> >>
> >> m-controls/build/jars/beehive-webservice-
> control.jar:/perf/beehive/trunk/wsm/build/jars/beehive-wsm.jar:/perf/
> >>
> >> beehive/trunk/wsm/build/jars/beehive-wsm-
> axis.jar:/perf/beehive/trunk/wsm/build/jars/beehive-wsdltypes.jar:/pe
> >>
> >>
>
rf/beehive/trunk/wsm/external/axis.jar:/perf/beehive/trunk/wsm/external/
ja
> xrpc.jar:/perf/beehive/trunk/wsm/ext
> >>
> >> ernal/wsdl4j.jar:/perf/beehive/trunk/system-
> controls/external/commons/commons-cli-1.0.jar:/perf/beehive/trunk/
> >>
> >> external/servlet/servlet-api-
> 2.4.jar:/perf/beehive/trunk/external/servlet/jsp-api-
> 2.0.jar:/perf/beehive/trunk/
> >>
> >> controls/build/jars/beehive-
>
controls.jar:/perf/beehive/trunk/external/junit/junit.jar:/perf/beehive/
tr
> unk/exte
> >>
> >> rnal/xmlbeans/apache-
>
xbean.jar:/perf/beehive/trunk/installed/jsr173/jsr173_1.0_api.jar:/perf/
be
> ehive/trunk/ext
> >>
> >> ernal/log4j/log4j-
> 1.2.8.jar:/perf/beehive/trunk/external/velocity/velocity-
> 1.4.jar:/perf/beehive/trunk/externa
> >>
> >> l/velocity/velocity-dep-
> 1.4.jar:/perf/beehive/trunk/external/commons/commons-logging-
> 1.0.4.jar:/perf/beehive/t
> >>
> >> runk/external/commons/commons-discovery-0.2.jar
> >>
> >> BUILD FAILED
> >> /perf/beehive/trunk/build.xml:228: The following error occurred
while
> >> executing this line:
> >> /perf/beehive/trunk/distribution.xml:69: The following error
occurred
> >> while executing this line:
> >> /perf/beehive/trunk/distribution.xml:238: The following error
occurred
> >> while executing this line:
> >> /perf/beehive/trunk/samples/build.xml:83: The following error
occurred
> >> while executing this line:
> >> /perf/beehive/trunk/samples/controls-webservices-blank/build-
> svn.xml:113:
> >> java.lang.NoClassDefFoundError: java
> >> x/jws/soap/SOAPBinding$Style
> >>
> >> Total time: 1 minute 25 seconds
> >> [netui@usbodell650-9 trunk]$
> >>
> >> Eddie O'Neil wrote:
> >>
> >>>
> >>>   Yep.  Just committed something similar.  Try SVN 179438.
> >>>
> >>> Eddie
> >>>
> >>>
> >>>
> >>> Patrick Osborne wrote:
> >>>
> >>>>
> >>>> I fixed it with this mod:
> >>>>
> >>>>
> >>>> Index: systemcontrols-imports.xml
> >>>>
===================================================================
> >>>> --- systemcontrols-imports.xml  (revision 179422)
> >>>> +++ systemcontrols-imports.xml  (working copy)
> >>>> @@ -17,7 +17,7 @@
> >>>>         <fileset
> >>>> file="${beehive.home}/wsm/build/jars/beehive-wsm.jar"/>
> >>>>         <fileset
> >>>> file="${beehive.home}/wsm/build/jars/beehive-wsm-axis.jar"/>
> >>>>         <fileset
> >>>> file="${beehive.home}/wsm/build/jars/beehive-wsdltypes.jar"/>
> >>>> -        <fileset file="${beehive.home}/wsm/lib/jsr181.jar"/>
> >>>> +        <fileset
file="${beehive.home}/wsm/build/jars/jsr181.jar"/>
> >>>>         <fileset file="${beehive.home}/wsm/external/axis.jar"/>
> >>>>         <fileset file="${beehive.home}/wsm/external/jaxrpc.jar"/>
> >>>>         <fileset file="${beehive.home}/wsm/external/wsdl4j.jar"/>
> >>>>
> >>>> Eddie O'Neil wrote:
> >>>>
> >>>>>
> >>>>>   I broke this -- must've had the jsr181.jar file stale in the
> >>>>> wsm/lib directory.
> >>>>>
> >>>>>   Will have a fix in momentarily; sorry about that.
> >>>>>
> >>>>> Eddie
> >>>>>
> >>>>>
> >>>>> Patrick Osborne wrote:
> >>>>>
> >>>>>>
> >>>>>> Hi,
> >>>>>>
> >>>>>> I'm having the following compile problem.  I checked out an
> >>>>>> entirely new client and I'm getting the same error.
> >>>>>> Any help would be appreciated.
> >>>>>>
> >>>>>> Thanks,
> >>>>>> Patrick.
> >>>>>>
> >>>>>>
> >>>>>> build:
> >>>>>>    [mkdir] Created dir:
> >>>>>> /perf/beehive2/trunk/system-controls/build/classes/webservice-
> control
> >>>>>>    [mkdir] Created dir:
> >>>>>> /perf/beehive2/trunk/system-controls/build/gensrc/webservice-
> control
> >>>>>>      [apt] Compiling 4 source files to
> >>>>>> /perf/beehive2/trunk/system-controls/build/classes/webservice-
> control
> >>>>>>      [apt]
> >>>>>> /perf/beehive2/trunk/system-
> controls/src/webservice/org/apache/beehive/controls/system/webservice/
> >>>>>>
> >>>>>> generator/ExtensionMaker.java:26: package javax.jws does not
exist
> >>>>>>      [apt] import javax.jws.WebParam;
> >>>>>>      [apt]                  ^
> >>>>>>      [apt] warning: Annotation types without processors:
> >>>>>> [org.apache.beehive.controls.api.bean.AnnotationMemb
> >>>>>> erTypes.FilePath]
> >>>>>>      [apt] 1 warning
> >>>>>>      [apt]
> >>>>>> /perf/beehive2/trunk/system-
> controls/src/webservice/org/apache/beehive/controls/system/webservice/
> >>>>>>
> >>>>>> generator/ExtensionMaker.java:26: package javax.jws does not
exist
> >>>>>>      [apt] import javax.jws.WebParam;
> >>>>>>      [apt]                  ^
> >>>>>>      [apt]
> >>>>>> /perf/beehive2/trunk/system-
> controls/src/webservice/org/apache/beehive/controls/system/webservice/
> >>>>>>
> >>>>>> generator/ExtensionMaker.java:179: package WebParam does not
exist
> >>>>>>      [apt]             if( param.getWpMode() ==
> >>>>>> WebParam.Mode.INOUT || param.getWpMode() == WebParam.Mode.OUT
> >>>>>> )  {
> >>>>>>      [apt]                                              ^
> >>>>>>      [apt]
> >>>>>> /perf/beehive2/trunk/system-
> controls/src/webservice/org/apache/beehive/controls/system/webservice/
> >>>>>>
> >>>>>> generator/ExtensionMaker.java:179: cannot access
javax.jws.WebParam
> >>>>>>      [apt] file javax/jws/WebParam.class not found
> >>>>>>      [apt]             if( param.getWpMode() ==
> >>>>>> WebParam.Mode.INOUT || param.getWpMode() == WebParam.Mode.OUT
> >>>>>> )  {
> >>>>>>      [apt]                                   ^
> >>>>>>      [apt]
> >>>>>> /perf/beehive2/trunk/system-
> controls/src/webservice/org/apache/beehive/controls/system/webservice/
> >>>>>>
> >>>>>> generator/ExtensionMaker.java:179: package WebParam does not
exist
> >>>>>>      [apt]             if( param.getWpMode() ==
> >>>>>> WebParam.Mode.INOUT || param.getWpMode() == WebParam.Mode.OUT
> >>>>>> )  {
> >>>>>>
> >>>>>> [apt]
> >>>>>> ^
> >>>>>>      [apt] Note: Some input files use unchecked or unsafe
> operations.
> >>>>>>      [apt] Note: Recompile with -Xlint:unchecked for details.
> >>>>>>      [apt] 4 errors
> >>>>>>
> >>>>>> BUILD FAILED
> >>>>>> /perf/beehive2/trunk/build.xml:61: The following error occurred
> >>>>>> while executing this line:
> >>>>>> /perf/beehive2/trunk/system-controls/build.xml:23: The
following
> >>>>>> error occurred while executing this line:
> >>>>>>
/perf/beehive2/trunk/system-controls/src/webservice/build.xml:31:
> >>>>>> The following error occurred while executing
> >>>>>> this line:
> >>>>>> /perf/beehive2/trunk/ant/beehive-tools.xml:72: Compile failed;
see
> >>>>>> the compiler error output for details.
> >>>>>>
> >>>>>> Total time: 1 minute 58 seconds
> >>>>>> [netui@usbodell650-9 trunk]$
> >>>>>
> >>>>>
> >>>>>
> >>>>>
> >>>>>
> >>>>>
> >>>>>
> >>>>
> >>>
> >>>
> >>
> >
> >



Mime
View raw message