beehive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Julie Zhuo (JIRA)" <>
Subject [jira] Closed: (BEEHIVE-403) ant build.dist.archives does not work from DOS window
Date Wed, 01 Jun 2005 21:05:54 GMT
     [ ]
Julie Zhuo closed BEEHIVE-403:

Verified fixed with both the m1 branch and trunk. The build.dist.archives run under DOS shell
now. the build file is now using the ant <tar> task.

> ant build.dist.archives does not work from DOS window
> -----------------------------------------------------
>          Key: BEEHIVE-403
>          URL:
>      Project: Beehive
>         Type: Bug
>   Components: Build
>     Versions: V1Beta, V1
>  Environment: Windows, DOS Shell, cygwin at end of my PATH and a drive letter in my paths
>     Reporter: Jim Cummings
>     Assignee: Julie Zhuo
>     Priority: Minor
>      Fix For: V1
>  Attachments: installed.db
> This is really 2 related problems:
> 1) When I run ant build.dist.archives from my DOS prompt, the .gz files do not generated.
 There are errors that go by, but the build still thinks it is successful.  In distribution.xml,
if you add a failonerror="true" attribute to the exec elements this lets it fail the build
if tar failed.  Might want to do this for the 'svn' execs as well.
> 2) The other problem is why the .gz files are not getting generated.  My path is finding
my cygwin GNU tar (version 1.13.25).  The cause is that tar is failing with this error:
>      [exec] D: Unknown Host
>      [exec] apache-beehive-incubating-svn-snapshot/docs/apidocs/classref_controls/org/apache/beehive/controls/api/bean/ControlInterface.html
>      [exec] tar (child): D\:\\beehive_trunk\\trunk\\build\\dist\\archives/apache-beehive-incubating-svn-snapshot.tar.gz:
Cannot open: Input/Output error
>      [exec] tar (child): Error is not recoverable: exiting now
> Apparently GNU tar fails with the "Unknown Host" error if you use drive letters in your
file paths.  I tried taking it out of my BEEHIVE_HOME, but the drive letter crops up from
somewhere else still.  If you add this as the 1st argument to the exec tar element it seems
to fix the problem. 
>      <arg value="--force-local"/>

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
For more information on JIRA, see:

View raw message